Bug 1121603 - [SNAPSHOT]: man or info page of gluster needs to be updated with snapshot commands
Summary: [SNAPSHOT]: man or info page of gluster needs to be updated with snapshot com...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: RHGS 3.0.0
Assignee: Sachin Pandit
QA Contact: Rahul Hinduja
URL:
Whiteboard: SNAPSHOT
Depends On:
Blocks: 1122399 1145069 1145084
TreeView+ depends on / blocked
 
Reported: 2014-07-21 10:56 UTC by Rahul Hinduja
Modified: 2016-09-17 12:56 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.6.0.27-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1122399 (view as bug list)
Environment:
Last Closed: 2014-09-22 19:44:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description Rahul Hinduja 2014-07-21 10:56:59 UTC
Description of problem:
=======================

Current man page is very outdated it doesn't have core self heal commands. With the new addition of snapshot command, please update the man page with snapshot commands, heal commands and any other commands which are left out.


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.6.0.24-1.el6rhs.x86_64


How reproducible:
=================
1/1


Steps to Reproduce:
===================
1. man gluster

Actual results:
===============
It doesn't have any heal or snapshot related commands.


Expected results:
=================

man page of gluster should have information about gluster heal and snapshot commands

Comment 1 Sachin Pandit 2014-07-23 07:20:23 UTC
I have renamed the bug, Because self-heal and snapshot are 2 different
components and its better to have 2 different bug raised for that.
Renaming this bug to make it more specific to snapshot commands.

Comment 2 Avra Sengupta 2014-07-25 06:21:49 UTC
Snapshot being a new feature in Denali, needs to provide command information in the man page, for any admin/user to familiarize themselves. Hence it makes sense to have this in the Denali with which we are launching snapshots.

Comment 4 Rahul Hinduja 2014-08-18 10:58:59 UTC
Verified with build: glusterfs-3.6.0.27-1.el6rhs.x86_64

"man gluster" and "info gluster" shows the gluster snapshot information as follows





   Snapshot Commands
        snapshot   create  <snapname>  <volname>  [description  <description>]
       [force]
              Creates  a  snapshot  of  a GlusterFS volume. User can provide a
              snap-name and a description to identify the snap.  The  descrip-
              tion  cannot  be more than 1024 characters. To be able to take a
              snapshot, volume should be present and it should be  in  started
              state.

        snapshot restore <snapname>
              Restores  an already taken snapshot of a GlusterFS volume. Snap-
              shot restore is an offline activity therefore if the  volume  is
              online  (in started state) then the restore operation will fail.
              Once the snapshot is restored it will not be  available  in  the
              list of snapshots.

        snapshot delete <snapname>
              Deletes the specified snapshot.

        snapshot list [volname]
              Lists all snapshots taken. If volname is provided, then only the
              snapshots belonging to that particular volume is listed.

        snapshot info [snapname | (volume <volname>)]
              This command gives information such as snapshot  name,  snapshot
              UUID,  time at which snapshot was created, and it lists down the
              snap-volume-name, number of snapshots already taken  and  number
              of snapshots still available for that particular volume, and the
              state of the snapshot.

        snapshot status [snapname | (volume <volname>)]
              This command gives status of the snapshot. The details  included
              are  snapshot  brick  path, volume group(LVM details), status of
              the snapshot bricks, PID of the bricks, data  percentage  filled
              for  that  particular volume group to which the snapshots belong
              to, and total size of the logical volume.

              If snapname is specified then status of the  mentioned  snapshot
              is  displayed.  If volname is specified then status of all snap-
              shots belonging to that volume is displayed.  If  both  snapname
              and  volname  is  not specified then status of all the snapshots
              present in the system are displayed.

        snapshot config [volname]  ([snap-max-hard-limit  <count>]  [snap-max-
       soft-limit <percent>]) | ([auto-delete <enable|disable>])
              Displays and sets the snapshot config values.

              snapshot config without any keywords displays the snapshot  con-
              fig values of all volumes in the system. If volname is provided,
              then the snapshot config values of that volume is displayed.

              Snapshot config command along  with  keywords  can  be  used  to
              change  the  existing config values. If volname is provided then
              config value of that volume is changed, else it will  set/change
              the system limit.

              snap-max-soft-limit  and  auto-delete  are  global options, that
              will be inherited by all volumes in the system and cannot be set
              to individual volumes.

              The  system  limit  takes  precedence  over  the volume specific
              limit.

              When auto-delete feature is  enabled,  then  upon  reaching  the
              soft-limit,  with every successful snapshot creation, the oldest
              snapshot will be deleted.

              When auto-delete feature is disabled,  then  upon  reaching  the
              soft-limit,  the user gets a warning with every successful snap-
              shot creation.

              Upon reaching the hard-limit, further  snapshot  creations  will
              not be allowed.

        snapshot activate <snapname>
              Activates the mentioned snapshot.

              Note : By default the snapshot is activated during snapshot cre-
              ation.

        snapshot deactivate <snapname>
              Deactivates the mentioned snapshot.


Moving the bug to verified state

Comment 6 errata-xmlrpc 2014-09-22 19:44:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.