Bug 1122399 - [SNAPSHOT]: man or info page of gluster needs to be updated with snapshot commands
Summary: [SNAPSHOT]: man or info page of gluster needs to be updated with snapshot com...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Sachin Pandit
QA Contact:
URL:
Whiteboard: SNAPSHOT
Depends On: 1121603
Blocks: 1145069 1145084
TreeView+ depends on / blocked
 
Reported: 2014-07-23 07:22 UTC by Sachin Pandit
Modified: 2015-07-26 22:05 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1121603
: 1145069 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:27 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sachin Pandit 2014-07-23 07:22:22 UTC
+++ This bug was initially created as a clone of Bug #1121603 +++

Description of problem:
=======================

Current man page is very outdated it doesn't have core self heal commands. With the new addition of snapshot command, please update the man page with snapshot commands, heal commands and any other commands which are left out.


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.6.0.24-1.el6rhs.x86_64


How reproducible:
=================
1/1


Steps to Reproduce:
===================
1. man gluster

Actual results:
===============
It doesn't have any heal or snapshot related commands.


Expected results:
=================

man page of gluster should have information about gluster heal and snapshot commands

--- Additional comment from Sachin Pandit on 2014-07-23 03:20:23 EDT ---

I have renamed the bug, Because self-heal and snapshot are 2 different
components and its better to have 2 different bug raised for that.
Renaming this bug to make it more specific to snapshot commands.

Comment 1 Anand Avati 2014-07-23 10:56:00 UTC
REVIEW: http://review.gluster.org/8357 (doc : man page for snapshot commands.) posted (#1) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 2 Anand Avati 2014-07-23 11:37:15 UTC
REVIEW: http://review.gluster.org/8357 (doc : man page for snapshot commands.) posted (#2) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 3 Anand Avati 2014-07-24 10:08:06 UTC
REVIEW: http://review.gluster.org/8357 (doc : man page for snapshot commands.) posted (#3) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 4 Anand Avati 2014-07-24 11:44:55 UTC
REVIEW: http://review.gluster.org/8357 (doc : man page for snapshot commands) posted (#4) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 5 Anand Avati 2014-07-25 06:46:19 UTC
COMMIT: http://review.gluster.org/8357 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit fb730072c27c9ae1b99ff41dbff45e721017d543
Author: Sachin Pandit <spandit@redhat.com>
Date:   Wed Jul 23 08:24:19 2014 +0530

    doc : man page for snapshot commands
    
    This patch also contains few modifications in admin documentation.
    
    Change-Id: I7bc2a88e6cbcfe81dcfafc2956f5b7c5524b0f0b
    BUG: 1122399
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/8357
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.