Bug 1121644 - rhevm-dwh-setup fails upgrading to 3.3.4-1
Summary: rhevm-dwh-setup fails upgrading to 3.3.4-1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: 3.3.4-1
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
: 1121943 (view as bug list)
Depends On: 1121642
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:04 UTC by rhev-integ
Modified: 2019-04-28 10:48 UTC (History)
18 users (show)

Fixed In Version: is37.1 - rhevm-dwh-3.3.4-2.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, on upgrade from 3.2 with a local database, "ovirt-engine-dwh-setup" was failing, due to a bug introduced in 3.3.4-1 when updating the postgresql-server pg_hba.conf configuration file. Now this command does not fail anymore.
Clone Of: 1121642
Environment:
Last Closed: 2014-07-24 15:38:36 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0929 normal SHIPPED_LIVE rhevm-dwh 3.3.4-2 bug fix update 2014-07-24 19:38:10 UTC
oVirt gerrit 30511 ovirt-engine-dwh-3.3 MERGED packaging: setup: fix updating pg_hba.conf Never
Red Hat Knowledge Base (Solution) 1128533 None None None Never

Comment 3 Yedidyah Bar David 2014-07-22 13:16:25 UTC
Note to QE:

Considering the history of this code, please verify:

1. Clean 3.3 setup
2. Clean 3.2 upgraded to 3.3
3. above, with manually editing pg_hba (see bugs #1084760 #1111131)

Comment 4 Yaniv Lavi 2014-07-24 14:55:31 UTC
Yedidyah Bar David:
Here was the actual bug - the 'local' line does not have an address, and so was not found. This wasn't a problem on clean setup because the default is ok, but 3.2 changed it to use 'md5'.

Comment 6 errata-xmlrpc 2014-07-24 15:38:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0929.html

Comment 7 Yaniv Lavi 2014-07-28 09:05:21 UTC
*** Bug 1121943 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.