Bug 1121653 - [RFE] "Open in full screen" checkbox should be controlled by a global setting in "rhevm-config"
Summary: [RFE] "Open in full screen" checkbox should be controlled by a global setting...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.0-alpha
: 4.0.0
Assignee: Marek Libra
QA Contact: meital avital
URL:
Whiteboard:
: 1325087 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:35 UTC by Pratik Pravin Bandarkar
Modified: 2016-08-23 20:20 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, users can use engine-config to set whether console windows open in full screen by default. The value can be set independently for the Administration Portal, Basic User Portal, and Extended User Portal. Consoles retrieved via REST share settings with the Administration Portal. The default can be set via engine-config by setting FullScreenWebadminDefault, FullScreenUserportalBasicDefault, and FullScreenUserportalExtendedDefault options.
Clone Of:
Environment:
Last Closed: 2016-08-23 20:20:59 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 55573 master MERGED webadmin: open in full screen default in vdc_options 2016-04-10 14:22:33 UTC

Description Pratik Pravin Bandarkar 2014-07-21 13:35:05 UTC
1. Proposed title of this feature request  
"Open in full screen" checkbox should be controlled by a setting in "rhevm-config". i.e. there should be an parameter in rhevm-config which will decide if the "Open in full screen" checkbox should be checked or unchecked.
---
user portal --> Basic tab --> select vm --> click on SPICE(Edit) --> "Open in Full Screen".
---

Comment 4 Michal Skrivanek 2015-04-27 08:38:12 UTC
we have a client-side property (configurable in Console Options)
system wide default is user portal - fullscreen, webadmin - window.

it can be also added as a VM-side property, but it can't be enforced...so is it useful?

Comment 5 Sigbjorn Lie 2015-04-27 09:54:21 UTC
Yes, that would be useful.

The point is not to force the user into full screen or window mode. The users complain that the VDI sessions are started in full screen, when they only wanted it in a window on their desktop.

We deployed VDI on RHEV 3.3, where window mode was the default for the user portal. This changed in 3.4 where full screen mode became the default in the user portal.

By making the default setting in the user portal configurable by the administrator you make it more usable for environments who require a kiosk mode (full screen, no need for access to the original desktop), AND environments like ours where the VDI session is in addition to their normal desktop, not a replacement for it. (Our Linux desktop users use Windows VDI to access Windows, and our Windows desktop users use Linux VDI to access Linux.)

This setting should be configurable in rhevm-config or in a per-vm setting. We do not use a rhevm pool to provide the VDI, so a per pool setting would be of no use.

Thanks.

Comment 9 Michal Skrivanek 2016-02-22 12:35:08 UTC
global default should be simple and conver the original use case
I wouldn't do per-VM...a bit too much work, and we do have a per-user setting already

Comment 11 Tomas Jelinek 2016-05-30 07:22:22 UTC
*** Bug 1325087 has been marked as a duplicate of this bug. ***

Comment 12 Michal Skrivanek 2016-06-01 14:06:48 UTC
probably in the current build

Comment 13 meital avital 2016-07-26 06:58:09 UTC
Verified on version: 4.0.2-0.2.rc1.el7ev

Please see Polarion cases.

Comment 15 errata-xmlrpc 2016-08-23 20:20:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.