Bug 112169 - sysctl in procps-2.0.17-6 depends on /usr/lib/libncurses.so.5
sysctl in procps-2.0.17-6 depends on /usr/lib/libncurses.so.5
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: procps (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
: 113309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 12:55 EST by Jonathan Kamens
Modified: 2007-04-18 13:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 18:51:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-12-15 12:55:54 EST
Sysctl fails for me upon system startup because it is trying to use
/usr/lib/libncurses.so.5, which doesn't exist yet since /usr hasn't
been mounted.
Either sysctl can't use curses, or the curses shared library needs to
move to /lib, or sysctl needs to link against the static curses library.
Comment 1 Jonathan Kamens 2003-12-15 13:33:48 EST
Ditto for libgpm.
Comment 2 Bernie Innocenti 2003-12-27 12:24:25 EST
I confirm this bug.
Comment 3 Aleksey Nogin 2004-01-19 00:26:38 EST
*** Bug 113309 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Larsson 2004-01-19 05:42:19 EST
notting, what is your opinion on this?
Comment 5 Bill Nottingham 2004-01-19 12:11:47 EST
sysctl has no gui/tui, unless it's changed. Why is it linked against
ncurses?
Comment 6 Alexander Larsson 2004-01-20 04:10:00 EST
Right. The curses addition seems to be in the selinux patch:
+sysctl:        % : %.o
+       $(strip $(CC)  $(LDFLAGS) -o $@ $< $(LIB_TGT) $(LIBCURSES)
$(SELINUX_LIBS))

This seems like a mistake in the patch.
Comment 7 Daniel Walsh 2004-01-20 18:51:03 EST
Removed the link from the SELinux patch in procps-2.0.17-7

Dan

Note You need to log in before you can comment on or make changes to this bug.