Bug 113309 - /sbin/sysctl depends on libncurses.so and libgpm.so, not available at boot time
Summary: /sbin/sysctl depends on libncurses.so and libgpm.so, not available at boot time
Status: CLOSED DUPLICATE of bug 112169
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: procps   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-12 13:37 UTC by Moritz Barsnick
Modified: 2007-04-18 17:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Moritz Barsnick 2004-01-12 13:37:26 UTC
Description of problem:
/sbin/sysctl is called at boot time, somewhere in one of the first 
boot scripts. On my system, it immediately fails, because libncurses.
so.x, which is located in the /usr filesystem space, is not 
available. libgpm.so is also missing, btw.

Version-Release number of selected component (if applicable):
procps-2.0.17-6

How reproducible:
always on systems where /usr is on a separate partition

Steps to Reproduce:
1. boot

or alternatively:

1. unmount all filesystems != / (where the latter includes /sbin, 
/lib, ...)
2. /sbin/sysctl
  
Actual results:
Program not started, missing dyn lib

Expected results:
Program runs.

Additional info:
Programs used at boot time should never depend on libraries which are 
not in /lib. So either:
a) Use a different program in the boot scripts.  ;-)
b) Link libncurses and libgpm statically to sysctl. :-P
c) Move libncurses.so* and libgpm.so* from /usr/lib to /lib.
d) Build something like a "/sbin/sysctl-minimal" (like
   "vim-minimal" or "aumix-minimal") and use this in the boot
   scripts, and move the full featured sysctl to /usr/bin.

Thanks,
Moritz.

Comment 1 Miloslav Trmac 2004-01-13 09:13:04 UTC
Duplicate of bug 112169
Triage->Duplicate 112169

Comment 2 Aleksey Nogin 2004-01-19 05:26:35 UTC

*** This bug has been marked as a duplicate of 112169 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.