Bug 1121722 - PPC64: mate-display-properties killed by SIGSEGV
Summary: PPC64: mate-display-properties killed by SIGSEGV
Keywords:
Status: CLOSED DUPLICATE of bug 1062796
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-control-center
Version: 20
Hardware: ppc64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 17:29 UTC by Al Dunsmuir
Modified: 2014-07-26 08:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 08:26:42 UTC


Attachments (Terms of Use)
gdb traceback (2.51 KB, text/plain)
2014-07-21 17:29 UTC, Al Dunsmuir
no flags Details

Description Al Dunsmuir 2014-07-21 17:29:57 UTC
Created attachment 919715 [details]
gdb traceback

Description of problem:  Make display-properties dialog frequently terminates with SIGSEGV when updating video mode.  Only happens when VGA attached.


Version-Release number of selected component (if applicable):
mate-control-center-1.6.2-3.fc20.ppc64


How reproducible:
More often then not, when adjusting display resolution after boot

Steps to Reproduce:
1. Boot with VGA-attached display
2. Kernel/X11 combo gives minimal resolution
3. Run mate-display properites to correct.... select resolution, hit ENTER.
   boom

Actual results:
SigSEGV
abrt traceback (which is not handled correctly on ppc64)
- See https://bugzilla.redhat.com/show_bug.cgi?id=1119072

Expected results:
Display resolution set

Additional info:

GDB traceback is same as that abrt had issues with (resolved, need build of fix).   

Also am getting occasional SIGSEGV for Caja that may be due to same underlying problem.

Other reports (generated by abrt and otherwise) for similar bug on other archs.

Comment 1 Wolfgang Ulbrich 2014-07-26 08:26:42 UTC

*** This bug has been marked as a duplicate of bug 1062796 ***


Note You need to log in before you can comment on or make changes to this bug.