Bug 112182 - Installer hangs in pre-install stage
Installer hangs in pre-install stage
Status: CLOSED DUPLICATE of bug 109462
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 14:48 EST by Philippe Rigault
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2003-12-15 14:48:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
I encounter two problems when upgrading from RedHat 8.0 to Fedora core 1.

Hardware:
  Dell Inspiron 8000
  1400x1050 LCD display
  ATI rage 128 mobility

The problems are:

1. X server fails to start by default. It seems that it does not detect the monitor (DELL 1400x1050 Laptop Display Panel) correctly. Booting with the following option solves this:
	linux 'resolution=1400x1050'
then the X server starts correctly, and the correct monitor can be selected during the install.

2. Installer hangs in pre-install stage. The install mode selected is  "upgrade existing system"
Finding packages to upgrade and checking dependencies proceeds OK.

Then , after starting the actuall install (click 'Next'), the following error message appear:

"An error occured transfering the install image to your hard drive. you are probably out of disk space."

...which I seriously doubt
If I click 'Next' again after this, I get this backtrace:

An unhandled exception has occured. This is most likely a bug.
Please copy the full text of this exception and file a detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla

Traceback (most recent call last):
 File "/usr/lib/anaconda.gui.py", line 1047, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/iw/progress_gui.py", line 242, in handleRenderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda.gui.py", line 766, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/dispatch.py", line 168, in gotoNext
  self.moveStep()
 File "/usr/lib/dispatch.py", line 236, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/packages.py", line 669, in doPreInstall
  f = open(instPath + "/etc/mtab", "w+")
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/mtab'






Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system with Fedore Core 1 install CD #1
2. Select 'Upgrade existing system'.
3. Begin the install. Installer hangs in Pre-install
    

Actual Results:  Installer hangs

Additional info:
Comment 1 Philippe Rigault 2003-12-15 17:18:25 EST
Marked as duplicate of  109462 
https://bugzilla.redhat.com/bugzilla/long_list.cgi?buglist=109462 
 
Booting with the following options works now: 
 
linux allowcddma 'resolution=1400x1050' 
 
 

*** This bug has been marked as a duplicate of 109462 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.