Bug 1122006 - NPE raised after RemoveDiskCommand
Summary: NPE raised after RemoveDiskCommand
Keywords:
Status: CLOSED DUPLICATE of bug 1121379
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Yair Zaslavsky
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 10:50 UTC by Raz Tamir
Modified: 2015-03-05 00:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 04:59:49 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine log (3.97 MB, text/plain)
2014-07-22 10:50 UTC, Raz Tamir
no flags Details

Description Raz Tamir 2014-07-22 10:50:42 UTC
Created attachment 919869 [details]
engine log

Description of problem:
After selecting few vm's disks and remove, in engine log a NPE raised after RemoveDiskCommand.


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch


How reproducible:


Steps to Reproduce:
1. select vm's disks
2. remove them
3.

Actual results:
In engine log a NPE will raise

Expected results:
NPE shouldn't raise anyway

Additional info:

Comment 1 Allon Mureinik 2014-07-22 13:28:38 UTC
Another missing constructor issue:

2014-07-21 12:08:20,353 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (org.ovirt.thread.pool-8-thread-47) An exception has occured while trying to create a command object for command RemoveImage: java.lang.RuntimeException: could not find matching constructor for Command class class org.ovirt.engine.core.bll.RemoveImageCommand
	at org.ovirt.engine.core.bll.CommandsFactory.findCommandConstructor(CommandsFactory.java:197) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandsFactory.createCommand(CommandsFactory.java:61) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandsFactory.createCommand(CommandsFactory.java:53) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CoCoAsyncTaskHelper.endAction(CoCoAsyncTaskHelper.java:315) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandCoordinatorImpl.endAction(CommandCoordinatorImpl.java:332) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.EndCommandAction(CommandAsyncTask.java:149) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.access$000(CommandAsyncTask.java:28) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandAsyncTask$1.run(CommandAsyncTask.java:109) [bll.jar:]
	at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:90) [utils.jar:]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_65]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_65]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_65]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_65]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_65]


Yair - I thought you got this one already?
Or am I confusing with another one?

Comment 2 Yair Zaslavsky 2014-07-23 04:59:49 UTC
Allon, didn't derez handle this?

http://gerrit.ovirt.org/#/c/30546/3/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java

I am closing as dup of the related bug.

derez took care of the exact missing ctor.

*** This bug has been marked as a duplicate of bug 1121379 ***


Note You need to log in before you can comment on or make changes to this bug.