Bug 1121379 - NPE and RTE occurs when cold moving vm's disks between different domains types
Summary: NPE and RTE occurs when cold moving vm's disks between different domains types
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Jiri Belka
URL:
Whiteboard: infra
: 1122006 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 08:38 UTC by Raz Tamir
Modified: 2016-02-10 19:30 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:28:19 UTC
oVirt Team: Infra


Attachments (Terms of Use)
engine log (11.49 MB, text/plain)
2014-07-20 08:38 UTC, Raz Tamir
no flags Details
new engine log (11.49 MB, text/plain)
2014-07-21 09:23 UTC, Raz Tamir
no flags Details
valid engine log (2.31 MB, text/plain)
2014-07-21 10:41 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30526 master MERGED core: RemoveImageCommand - missing constructor Never
oVirt gerrit 30546 ovirt-engine-3.5 MERGED core: RemoveImageCommand - missing constructor Never

Description Raz Tamir 2014-07-20 08:38:32 UTC
Created attachment 919332 [details]
engine log

Description of problem:
When cold moving vm's disks from NFS domain to iSCSI domain a NullPointerException and RuntimeException raised after RemoveImageCommand executes


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
explained above

Expected results:
Should work with no exceptions 

Additional info:

Comment 1 Daniel Erez 2014-07-21 08:37:57 UTC
Hi Raz,

According to the logs the failure caused by a live migration [1] (which should be covered by bug 1121400). Can you attach the engine log with invocation of cold move?

[1]
2014-07-16 08:51:23,773 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (ajp--127.0.0.1-8702-9) [78eac9c0] Cant find constructor for type org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand with parameter types: [class org.ovirt.engine.core.common.action.LiveMigrateVmDisksParameters]
2014-07-16 08:51:23,774 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (ajp--127.0.0.1-8702-9) [78eac9c0] An exception has occured while trying to create a command object for command LiveMigrateVmDisks: java.lang.RuntimeException: could not find matching constructor for Command class class org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand

Comment 2 Raz Tamir 2014-07-21 09:23:53 UTC
Created attachment 919569 [details]
new engine log

Provided new logs.
The original log is full with exceptions.
Look for "2014-07-21 12:08:20,340" in the new log.
The exception is after the RemoveImageCommand

Comment 3 Raz Tamir 2014-07-21 10:41:42 UTC
Created attachment 919605 [details]
valid engine log

The previous attached log ('new engine log') is not the correct one.
Attaching a valid engine log

Comment 4 Daniel Erez 2014-07-21 12:28:34 UTC
(In reply to ratamir from comment #3)
> Created attachment 919605 [details]
> valid engine log
> 
> The previous attached log ('new engine log') is not the correct one.
> Attaching a valid engine log

Thanks Raz.

Exception caused by a missing ctr:
2014-07-21 13:25:50,758 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (org.ovirt.thread.pool-8-thread-8) [27e704b7] Cant find constructor for type org.ovirt.engine.core.bll.RemoveImageCommand with parameter types: [class org.ovirt.engine.core.common.action.RemoveImageParameters]
2014-07-21 13:25:50,774 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (org.ovirt.thread.pool-8-thread-8) [27e704b7] An exception has occured while trying to create a command object for command RemoveImage: java.lang.RuntimeException: could not find matching constructor for Command class class org.ovirt.engine.core.bll.RemoveImageCommand

Comment 5 Allon Mureinik 2014-07-21 12:47:02 UTC
(In reply to Daniel Erez from comment #4)
> Exception caused by a missing ctr:
Setting whiteboard=infra to track together with the others

Comment 6 Yair Zaslavsky 2014-07-23 04:59:49 UTC
*** Bug 1122006 has been marked as a duplicate of this bug. ***

Comment 7 Jiri Belka 2014-09-11 11:35:42 UTC
ok, can't reproduce on rhevm-backend-3.5.0-0.11.beta.el6ev.noarch while moving a vm's disk from nfs to iscsi domain.

Comment 8 Sandro Bonazzola 2014-10-17 12:28:19 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.