Bug 1122198 - vdsm package for el7 does not contain tmpfiles.d/vdsm.conf for systemd
Summary: vdsm package for el7 does not contain tmpfiles.d/vdsm.conf for systemd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 3.4.4
Assignee: Yaniv Bronhaim
QA Contact: Petr Kubica
URL:
Whiteboard: infra
: 1144909 (view as bug list)
Depends On:
Blocks: 1144279 1154665
TreeView+ depends on / blocked
 
Reported: 2014-07-22 18:26 UTC by Stanislav Mikhalevich
Modified: 2014-12-15 15:07 UTC (History)
13 users (show)

Fixed In Version: v4.16.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 08:09:11 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30820 master MERGED RHEL7 works with systemd and requires systemd macros and tmpfiles.d conf Never
oVirt gerrit 31086 ovirt-3.5 MERGED RHEL7 works with systemd and requires systemd macros and tmpfiles.d conf Never
oVirt gerrit 33021 ovirt-3.4 MERGED RHEL7 works with systemd and requires systemd macros and tmpfiles.d conf Never

Description Stanislav Mikhalevich 2014-07-22 18:26:44 UTC
Description of problem:
vdsm package contains /var/run/vdsm/{payload,sourceRoutes,trackedInterfaces}.
vdsm package for el7 does not contain tmpfiles.d/vdsm.conf for systemd. After reboot system /var/run does not contains vdsm dir and vdsm subdirs.

Version-Release number of selected component (if applicable):


How reproducible:
Install vdsm on CentOS 7. Reboot system.

Steps to Reproduce:
1. Install vdsm on CentOS 7
2. Reboot system
3.

Actual results:
[root@hv02 ~]# ls /var/run/vdsm/
lvm  nets_restored  svdsm.sock

Expected results:


Additional info:
In my opinion vdsm.spec.in need patch in this place
%if 0%{?fedora} >= 15 || 0%{?rhel} >= 7
%global with_systemd 1
%endif

%if 0%{?fedora} >= 18 (maybe also need || 0%{?rhel} >= 7)
%global with_systemd_macros 1
%global with_tmpfiles_macro 1
%endif

Comment 1 Antoni Segura Puimedon 2014-09-22 09:37:13 UTC
*** Bug 1144909 has been marked as a duplicate of this bug. ***

Comment 2 Sandro Bonazzola 2014-09-24 08:09:11 UTC
oVirt 3.4.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.