Bug 1144279 - [vdsm-reg el7]rhevh7.0 for rhev 3.4 build register to RHEV-M 3.4 failed
Summary: [vdsm-reg el7]rhevh7.0 for rhev 3.4 build register to RHEV-M 3.4 failed
Keywords:
Status: CLOSED DUPLICATE of bug 1128033
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1122198
Blocks: rhevh-7.0 rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-09-19 06:57 UTC by haiyang,dong
Modified: 2016-02-10 20:08 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-08 11:54:12 UTC
oVirt Team: Node


Attachments (Terms of Use)

Description haiyang,dong 2014-09-19 06:57:38 UTC
Description of problem:
After Installed rhev-h,then configure network and 
register to rhevm av11.2 , Although rhev-h shown that register into rhevm success
But the nic still named "em1", didn't rename "rhevm",and in fact didn't register.
Couldn't display rhevh host in rhevm web admin portal.

Also no vdsm-reg.log in /var/log/vdsm-reg/

service vdsmd start failed
-------------------------
[root@dhcp-9-232 admin]# service vdsmd status
Redirecting to /bin/systemctl status  vdsmd.service
vdsmd.service - Virtual Desktop Server Manager
   Loaded: loaded (/usr/lib/systemd/system/vdsmd.service; enabled)
   Active: failed (Result: start-limit) since Fri 2014-09-19 04:45:53 UTC; 22min ago
  Process: 2453 ExecStartPre=/usr/libexec/vdsm/vdsmd_init_common.sh --pre-start (code=exited, status=1/FAILURE)

Sep 19 04:45:53 localhost systemd[1]: vdsmd.service: control process exited, code=exited status=1
Sep 19 04:45:53 localhost systemd[1]: Failed to start Virtual Desktop Server Manager.
Sep 19 04:45:53 localhost systemd[1]: Unit vdsmd.service entered failed state.
Sep 19 04:45:53 localhost systemd[1]: vdsmd.service holdoff time over, scheduling restart.
Sep 19 04:45:53 localhost systemd[1]: Stopping Virtual Desktop Server Manager...
Sep 19 04:45:53 localhost systemd[1]: Starting Virtual Desktop Server Manager...
Sep 19 04:45:53 localhost systemd[1]: vdsmd.service start request repeated too quickly, refusing to start.
Sep 19 04:45:53 localhost systemd[1]: Failed to start Virtual Desktop Server Manager.
Sep 19 04:45:53 localhost systemd[1]: Unit vdsmd.service entered failed state.

[root@dhcp-9-232 admin]# journalctl -u vdsmd.service -b
-- Logs begin at Fri 2014-09-19 04:45:40 UTC, end at Fri 2014-09-19 05:08:01 UTC. --
Sep 19 04:45:48 localhost systemd[1]: Starting Virtual Desktop Server Manager...
Sep 19 04:45:48 localhost vdsmd_init_common.sh[1272]: vdsm: Running mkdirs
Sep 19 04:45:49 localhost vdsmd_init_common.sh[1272]: vdsm: Running configure_coredump
Sep 19 04:45:49 localhost vdsmd_init_common.sh[1272]: vdsm: Running configure_vdsm_logs
Sep 19 04:45:49 localhost vdsmd_init_common.sh[1272]: vdsm: Running run_init_hooks
Sep 19 04:45:49 localhost vdsmd_init_common.sh[1272]: vdsm: Running gencerts
Sep 19 04:45:49 localhost vdsmd_init_common.sh[1272]: vdsm: Running check_is_configured
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: libvirt is not configured for vdsm yet
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: Modules libvirt are not configured
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: Traceback (most recent call last):
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: File "/usr/bin/vdsm-tool", line 145, in <module>
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: sys.exit(main())
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: File "/usr/bin/vdsm-tool", line 142, in main
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: return tool_command[cmd]["command"](*args[1:])
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: File "/usr/lib64/python2.7/site-packages/vdsm/tool/configurator.py", line 283, in isconfigured
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: RuntimeError:
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: One of the modules is not configured to work with VDSM.
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: To configure the module use the following:
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: 'vdsm-tool configure [module_name]'.
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: If all modules are not configured try to use:
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: 'vdsm-tool configure --force'
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: (The force flag will stop the module's service and start it
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: afterwards automatically to load the new configuration.)
Sep 19 04:45:50 localhost vdsmd_init_common.sh[1272]: vdsm: stopped during execute check_is_configured task (task returned with error code 1).
Sep 19 04:45:50 localhost systemd[1]: vdsmd.service: control process exited, code=exited status=1
Sep 19 04:45:50 localhost systemd[1]: Failed to start Virtual Desktop Server Manager.
Sep 19 04:45:50 localhost systemd[1]: Unit vdsmd.service entered failed state.
Sep 19 04:45:50 localhost systemd[1]: vdsmd.service holdoff time over, scheduling restart.
Sep 19 04:45:50 localhost systemd[1]: Stopping Virtual Desktop Server Manager...


Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140918.0.iso
ovirt-node-3.1.0-0.13.20140918gitdda78cb.el7.noarch
vdsm-4.14.13-2.el7ev.x86_64
vdsm-reg-4.14.13-2.el7ev.noarch
ovirt-node-plugin-vdsm-0.1.2-3.el7ev.noarch
Red Hat Enterprise Virtualization Manager Version: 3.4.2-1.1.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.0-20140918.0.iso
2. Configure network for rhev-h
3. Register to rhevm av11.2.


Actual results:
After step3. Register to  rhevm av11.2failed.

Expected results:
Supporting that register rhev-h to RHEV-M av11.2

Additional info:

Comment 3 Douglas Schilling Landgraf 2014-09-22 01:53:06 UTC
Hi hadong,

Could you please confirm that you configured your network via DHCP? 
I do believe you got affected by: BZ#1144909

On the other hand, if you configure your network with static ip address, you will get affected by: BZ#1128033 

Can you please confirm the above statements? If that's the case, I would close this bug as dup of BZ#1144909

Thanks

Comment 4 haiyang,dong 2014-09-22 02:22:59 UTC
(In reply to Douglas Schilling Landgraf from comment #3)
> Hi hadong,
> 
> Could you please confirm that you configured your network via DHCP? 
> I do believe you got affected by: BZ#1144909
Configure network via dhcp

> 
> On the other hand, if you configure your network with static ip address, you
> will get affected by: BZ#1128033 
> 
> Can you please confirm the above statements? If that's the case, I would
> close this bug as dup of BZ#1144909
> 
> Thanks

Comment 5 Ying Cui 2014-09-22 08:14:50 UTC
(In reply to Douglas Schilling Landgraf from comment #3)
> Hi hadong,
> 
> Could you please confirm that you configured your network via DHCP? 
> I do believe you got affected by: BZ#1144909
> 
> On the other hand, if you configure your network with static ip address, you
> will get affected by: BZ#1128033 
> 
> Can you please confirm the above statements? If that's the case, I would
> close this bug as dup of BZ#1144909
> 
> Thanks
Hey Douglas, if you think fix 1144909 vdsm bug can indirectly or directly fix this ovirt-node bug too, you can mark this ovirt-node bug as Testonly, because this bug is Testblocker, RHEVH QE also need to verify it on ovirt-node side to ignore any risk here. Thanks.

Comment 7 Fabian Deutsch 2014-09-22 13:53:45 UTC
Might be a dupe of bug 1128033 , keeping it open to verify that this bug is fixed.

Comment 8 Douglas Schilling Landgraf 2014-09-22 13:59:39 UTC
As Toni shared in bz#1144909 it's a dup of BZ#1122198. So adding depends on bz#1122198.

Comment 9 Douglas Schilling Landgraf 2014-09-22 14:02:35 UTC
Hi Ying,

Moving to ON_QA since it's test only as Ying shared in comment#5. If it's incorrect fell free to change it again.

Comment 13 haiyang,dong 2014-10-08 11:54:12 UTC
Due to there will no 7.0 for 3.4.z build future, so this bug can be a dupe of bug 1128033

*** This bug has been marked as a duplicate of bug 1128033 ***


Note You need to log in before you can comment on or make changes to this bug.