Bug 112229 - Bad: /etc/init.d/hotplug missing
Bad: /etc/init.d/hotplug missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
1
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 08:53 EST by Joachim Nilsson
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 15:59:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Nilsson 2003-12-16 08:53:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807

Description of problem:
The Fedora Core #1 hotplug package, 2003_08_05, is missing the hotplug
startup script in /etc/init.d/hotplug - this is included in the
original package from linux-hotplug.sf.net.

If this script is not available at system startup devices requiring
firmware loading is not loaded properly.

Please include the missing functionality in the next Core release.

If you have removed /etc/init.d/hotplug because of its effect on the
bootup time, which is understandable, then please include a
hotplug-extras package or similar for us who really need this
functionality. As it is now we are forced to download the proper
packages from linux-hotplug.sf.net and do a

rpm -Uvh --force hotplug*.rpm



Version-Release number of selected component (if applicable):
hotplug-2003_08_05

How reproducible:
Always

Steps to Reproduce:
1. Find a USB device with firmware that needs to be loaded - e.g. an
FX2 development board or other similar device.
2. Setup your neat hotplug scripts that load the FX2 using fxload or
similar.
3. Plug in your device and restart the computer.
4. After reboot - check that the correct driver is loaded (also by
hotplug) and that the firmware was loaded properly ...
5. HEY - the firmware wasn't loaded!
6. Unplug and replug the device - et voil�! The firmware is now loaded.
7. We need to have /etc/init.d/hotplug AND have it start in runlevel 5
or whatever we choose to run. But Fedora Core #1 does not include this
script.
8. Bad Fedora.
    

Actual Results:  
Not what I expected. The firmware is not properly loaded because the
hotplug script in /etc/hotplug/usb/* is not executed for devices
plugged in at system start because there is no hotplug script to pick
up devices existing at system boot...

Expected Results:  The hotplug scripts for all connected devices
should be run at system startup - not just when they are plugged in.


Additional info:

Please read up on Hotplug.
Comment 1 Miloslav Trmac 2003-12-16 10:06:37 EST
Related to bug 65200 and bug 65452.
Comment 2 Bill Nottingham 2003-12-16 10:50:11 EST
There's a different issue here if you're not getting hotplug events
for usb devices at startup... you should still be getting them outside
of the hotplug script.
Comment 3 Bill Nottingham 2005-02-04 15:59:38 EST
Closing out bugs on older, no longer supported, releases. Apologies
for any lack of response. Please reopen if problems persist on more
current releases.

I believe the devices not working would be a symptom of another
problem; /etc/init.d/hotplug shouldn't be needed. Of course, this is
all handled differently in FC3 and later, and probably won't reoccur
in that context.

Note You need to log in before you can comment on or make changes to this bug.