Bug 1122328 - [GSS] (6.4.0) 'Compatible Change' Marshalling does not allow classes to be removed from the class hierarchy of a serialized class
Summary: [GSS] (6.4.0) 'Compatible Change' Marshalling does not allow classes to be re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR1
: EAP 6.4.0
Assignee: David M. Lloyd
QA Contact: Jitka Kozana
URL:
Whiteboard:
Depends On:
Blocks: 1104328 1122329
TreeView+ depends on / blocked
 
Reported: 2014-07-23 00:48 UTC by Brad Maxwell
Modified: 2019-08-19 12:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, a `ClassNotFoundException` was encountered during marshalling if a class was missing from the hierarchy of a serialized class. For example, if one system marshalled class A, which extended class B, which, in turn, extended class C, which was sent to a system that did not contain all three classes in the same hierarchy, an exception was encountered on the missing class. This issue has been addressed in this release of the product.
Clone Of: 1104328
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBMAR-162 Major Resolved Removing a class from a hierarchy causes CNFE 2015-11-13 11:00:07 UTC

Description Brad Maxwell 2014-07-23 00:48:08 UTC
+++ This bug was initially created as a clone of Bug #1104328 +++



--- Additional comment from Brad Maxwell on 2014-06-03 14:43:55 EDT ---

Resolved by component upgrade to  1.4.7.Final or later

--- Additional comment from Kabir Khan on 2014-07-01 10:51:10 EDT ---

Moving back to ASSIGNED since 6.3.0 is still on 1.4.7

Comment 2 sgilda 2014-07-29 19:31:12 UTC
Based on Bug 1123331: 

Bug Fixes in the Remoting section.
There are two issues duplicated: 1122328 and 1104328 are the same, 1102271 and 1122327 are also the same. Only one of each should remain.

This one is targeted for 6.4, so removing the requires_doc_text flag on this bug.

Comment 3 Kabir Khan 2014-08-26 20:20:40 UTC
Should be fixed by remoting upgrade to 1.4.8 https://bugzilla.redhat.com/show_bug.cgi?id=1122329

Comment 4 Ladislav Thon 2014-09-17 13:58:40 UTC
Verified with EAP 6.4.0.DR1.1.


Note You need to log in before you can comment on or make changes to this bug.