Bug 1123331 - JBoss Marshalling problems in release notes: duplication, known issue documented as bugfix, bad text for a bugfix
Summary: JBoss Marshalling problems in release notes: duplication, known issue documen...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: EAP 6.3.0
Assignee: Scott Mumford
QA Contact: Ladislav Thon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 10:45 UTC by Ladislav Thon
Modified: 2014-08-14 15:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 14:40:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Ladislav Thon 2014-07-25 10:45:00 UTC
In current version of 6.3.0 release notes (Revision 6.3.0-17), there are some issues in chapter 7.1. Bug Fixes in the Remoting section.

There are two issues duplicated: 1122328 and 1104328 are the same, 1102271 and 1122327 are also the same. Only one of each should remain.

In addition to that, 1122328/1104328 (that is, upstream issue JBMAR-162) was NOT fixed in 6.3.0, therefore it should be moved to chapter 7.3. Known Issues.

And last but not least, 1122327/1102271 (that is, upstream issue JBMAR-161) was indeed fixed in 6.3.0, but the release notes text describes a different issue (in fact, it describes a second part of JBMAR-162). Correct text should be provided.

(Also adding a needinfo for Brad, to whom I sent an e-mail yesterday describing this release notes problem in more detail.)

Comment 1 sgilda 2014-07-29 20:02:07 UTC
I did the following:

- Set the 'requires_doc_text' flag to '-' in Bug 1122327 because it is targeted for 6.4 and duplicates Bug 1102271.
- Set the 'requires_doc_text' flag to '-' in Bug 1122328 because it is targeted for 6.4 and duplicates Bug 1104328.
- Changed the Doc Type from 'Bug Fix' to 'Known Issue' in Bug 1104328 since it will not make the 6.3.0 release.
- Updated the release notes Doc Text field  in Bug 1104328 to indicate it's a known issue and not a bug fix.

The only outstanding issue is the last one: 
And last but not least, 1122327/1102271 (that is, upstream issue JBMAR-161) was indeed fixed in 6.3.0, but the release notes text describes a different issue (in fact, it describes a second part of JBMAR-162). Correct text should be provided.

Comment 2 sgilda 2014-07-29 20:23:24 UTC
Added proposed Release Notes text to the comment in Bug 1102271.

Comment 3 sgilda 2014-07-29 21:12:27 UTC
Modified the Release Notes text for Bug 1102271 based on discussions with Brad.

Comment 4 Lucas Costi 2014-07-31 04:13:52 UTC
Changes in comments 1 and 3 are now ready for review (Revision 6.3.0-18):

https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/6.3.0_Release_Notes/index.html

Comment 5 Ladislav Thon 2014-07-31 07:27:51 UTC
I'm moving this back to ASSIGNED to at least discuss this:

Bug 1104328 (first part of JBMAR-162) is now correctly documented as a Known Issue, but there is another known issue (second part of JBMAR-162) that isn't documented at all (release notes item for that second issue was previously provided as a Doc Text for bug 1102271, which was of course incorrect).

Do we want to document this too? It's probably fine if we decide we don't, because the entire JBMAR-161+JBMAR-162 problem only affects one customer (AFAIK), but it's worth thinking a bit.

--

Also, if we are back to ASSIGNED, one minor nitpick. The description of known issue 1104328 says: "A ClassNotFoundException may be encountered during marshalling if a class is missing from the hierarchy of a serialized class." If I'm not mistaken, the exception can happen during _unmarshalling_, not marshalling.

Comment 7 sgilda 2014-07-31 15:19:56 UTC
Fixed the text in Bug 1104328,

Comment 9 Ladislav Thon 2014-08-01 06:29:34 UTC
OK, so the decision seems to be to keep the second part of JBMAR-162 undocumented. Fine with me.

Reviewed in Revision 6.3.0-19.


Note You need to log in before you can comment on or make changes to this bug.