Bug 112245 - httpd still requires libdb-4.1.so?
httpd still requires libdb-4.1.so?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: httpd (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 112817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 11:41 EST by Kaj J. Niemi
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.0.48-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-02 08:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-12-16 11:41:12 EST
Description of problem:
There's something fishy with httpd-2.0.48, it's linked against both
bdb 4.1 and bdb 4.2 but requires only libdb-4.1.so?

% rpm -q --requires httpd-2.0.48-3|grep libdb
libdb-4.1.so

ldd `which httpd` |grep libdb
        libdb-4.1.so => /lib/libdb-4.1.so (0x0093d000)
        libdb-4.2.so => /lib/tls/libdb-4.2.so (0x003bc000)
Comment 1 Joe Orton 2004-01-02 08:59:41 EST
The -4 rebuild got rid of the libdb-4.1 deps; you'll need the newer
apr-util too.
Comment 2 Joe Orton 2004-01-03 08:27:53 EST
*** Bug 112817 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.