Bug 1122598 - DNF search crashes with UnicodeDecodeError
Summary: DNF search crashes with UnicodeDecodeError
Keywords:
Status: CLOSED DUPLICATE of bug 1118809
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:54 UTC by Martin Kolman
Modified: 2014-07-25 09:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 09:03:58 UTC


Attachments (Terms of Use)

Description Martin Kolman 2014-07-23 14:54:53 UTC
Description of problem:
$ dnf search meld
Copr repo for f20-gnome-3-12 owned by rhughes (i386)                                                                                                          219 kB/s | 1.0 MB     00:04    
RPM Fusion for Fedora 20 - Free - Updates                                                                                                                     129 kB/s | 387 kB     00:02    
RPM Fusion for Fedora 20 - Free                                                                                                                               160 kB/s | 487 kB     00:03    
RPM Fusion for Fedora 20 - Nonfree - Updates                                                                                                                  126 kB/s | 125 kB     00:00    
RPM Fusion for Fedora 20 - Nonfree                                                                                                                            116 kB/s | 289 kB     00:02    
Copr repo for f20-gnome-3-12 owned by rhughes (x86_64)                                                                                                         82 kB/s | 1.0 MB     00:12    
Brew Buildsystem for Fedora 20 - x86_64                                                                                                                        12 kB/s | 5.3 kB     00:00    
Fedora 20 - x86_64 - Updates                                                                                                                                   12 MB/s |  24 MB     00:02    
Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1170, in run
    self.base.plugins.run_sack()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 139, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/generate_completion_cache.py", line 55, in sack
    self._out('Can\'t write completion cache: %s' % e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)


Version-Release number of selected component (if applicable):

dnf --version
0.5.4
  Nainstalováno: dnf-0:0.5.4-1.fc20.noarch na 2014-07-22 09:21
  Sestaveno    : Fedora Project na 2014-07-17 06:30

  Nainstalováno: rpm-0:4.11.2-2.fc20.x86_64 na 2014-02-27 08:50
  Sestaveno    : Fedora Project na 2014-02-18 07:24

How reproducible:
Looks like to be happening only during the initial cache population as during subsequent attempts it works.


Steps to Reproduce:
1. dnf search meld

Actual results:
Crash!

Expected results:
No crash, shows information about any "meld" packages available from the repos.

Comment 1 Honza Silhan 2014-07-25 09:03:58 UTC

*** This bug has been marked as a duplicate of bug 1118809 ***


Note You need to log in before you can comment on or make changes to this bug.