Bug 1118809 - [abrt] dnf: generate_completion_cache.py:55:sack:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)
[abrt] dnf: generate_completion_cache.py:55:sack:UnicodeDecodeError: 'ascii' ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:21cf307945661be1c5605db5d66...
:
: 1122598 1123533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-11 10:53 EDT by Vít Ondruch
Modified: 2014-08-08 04:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 04:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.37 KB, text/plain)
2014-07-11 10:53 EDT, Vít Ondruch
no flags Details
File: environ (2.74 KB, text/plain)
2014-07-11 10:53 EDT, Vít Ondruch
no flags Details

  None (edit)
Description Vít Ondruch 2014-07-11 10:53:05 EDT
Description of problem:
Executing DNF using nonprivileged user.

Version-Release number of selected component:
dnf-0.5.3-1.fc21

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf search music
dso_list:       dnf-plugins-core-0.1.1-2.fc21.noarch
executable:     /usr/bin/dnf
kernel:         3.16.0-0.rc3.git3.1.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
generate_completion_cache.py:55:sack:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1167, in run
    self.base.plugins.run_sack()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 139, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/generate_completion_cache.py", line 55, in sack
    self._out('Can\'t write completion cache: %s' % e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)

Local variables in innermost frame:
repo: <Repo vondruch-doublecmd>
fresh: True
self: <dnf.plugin.dynamic.generate_completion_cache.BashCompletionCache object at 0x7f113ab82350>
e: IOError(13, 'Operace zam\xc3\xadtnuta')
Comment 1 Vít Ondruch 2014-07-11 10:53:09 EDT
Created attachment 917335 [details]
File: backtrace
Comment 2 Vít Ondruch 2014-07-11 10:53:11 EDT
Created attachment 917336 [details]
File: environ
Comment 3 Honza Silhan 2014-07-25 05:03:58 EDT
*** Bug 1122598 has been marked as a duplicate of this bug. ***
Comment 4 Ales Kozumplik 2014-07-28 01:00:41 EDT
*** Bug 1123533 has been marked as a duplicate of this bug. ***
Comment 5 Honza Silhan 2014-07-28 07:43:51 EDT
Fixed in the upstream.
Comment 6 Fedora Update System 2014-07-29 02:45:57 EDT
dnf-plugins-core-0.1.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.1-3.fc20
Comment 7 Fedora Update System 2014-07-30 03:04:12 EDT
Package dnf-plugins-core-0.1.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9013/dnf-plugins-core-0.1.1-3.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-08-08 04:36:44 EDT
dnf-plugins-core-0.1.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.