Bug 1122641 - Removing file(s) after 'scrub --freespace ...' not decribed in man page
Summary: Removing file(s) after 'scrub --freespace ...' not decribed in man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Nikola Forró
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks: 1392399
TreeView+ depends on / blocked
 
Reported: 2014-07-23 16:50 UTC by Stanislav Zidek
Modified: 2017-03-21 11:49 UTC (History)
7 users (show)

Fixed In Version: man-pages-overrides-6.9.0-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 11:49:30 UTC


Attachments (Terms of Use)
proposed patch for the scrub.1.in file (1.08 KB, patch)
2016-06-24 08:48 UTC, Daniel Kopeček
no flags Details | Diff
proposed patch for the generated scrub.1 file (1.09 KB, patch)
2016-06-24 08:49 UTC, Daniel Kopeček
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0783 normal SHIPPED_LIVE man-pages-overrides bug fix update 2017-03-21 12:49:29 UTC

Description Stanislav Zidek 2014-07-23 16:50:15 UTC
Description of problem:
According to bz903890, scrub --freespace removes the scrubbed file after filling up the space, but this behaviour is not reflected in manpage.

Version-Release number of selected component (if applicable):
scrub-2.2-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. man scrub

Actual results:
...
       -X, --freespace
              Create specified directory and fill it with files until write returns ENOSPC (file  system full), then scrub the files as usual.  The size of each file can be set with -s, otherwise it will be the maximum file size creatable given the user’s  file  size  limit  or  1g  if umlimited.
...

Expected results:
Something like:
...
       -X, --freespace
              Create specified directory and fill it with files until write returns ENOSPC (file  system full), scrub the files as usual, and then remove both files and the directory.  The size of each file can be set with -s, otherwise it will be the maximum file size creatable given the user’s  file  size  limit  or  1g  if umlimited.
...

Additional info:

Comment 4 Daniel Kopeček 2016-06-24 08:48:48 UTC
Created attachment 1171872 [details]
proposed patch for the scrub.1.in file

Comment 5 Daniel Kopeček 2016-06-24 08:49:19 UTC
Created attachment 1171873 [details]
proposed patch for the generated scrub.1 file

Comment 12 errata-xmlrpc 2017-03-21 11:49:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0783.html


Note You need to log in before you can comment on or make changes to this bug.