Bug 1122663 - [RFE] Staypuft should be able to setup node(s) as required for Ceph cluster (OSD only)
Summary: [RFE] Staypuft should be able to setup node(s) as required for Ceph cluster (...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: z1
: Installer
Assignee: Brad P. Crochet
QA Contact: Yogev Rabl
URL:
Whiteboard: MVP
: 1122667 (view as bug list)
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-07-23 17:40 UTC by arkady kanevsky
Modified: 2018-09-26 12:06 UTC (History)
16 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.3.2-1.el6ost
Doc Type: Enhancement
Doc Text:
With this update, two new node types have been added to the RHEL OpenStack Platform installer: * RHEL 7 Generic, which supports the creation of ad-hoc nodes that are not yet fully supported. * Ceph Node (OSD), which currently only has an OS installed and must have Ceph installed by the Ceph installer (future updates will include the node's complete configuration by the RHEL OpenStack Platform installer). Both nodes are only configured with Red Hat Enterprise Linux 7 and the openstack-common puppet class from Quickstack. The user must add any further configuration.
Clone Of:
: 1122667 (view as bug list)
Environment:
Last Closed: 2014-10-01 13:25:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description arkady kanevsky 2014-07-23 17:40:41 UTC
Description of problem:
For Ceph cluster deployment OSP deployer (Staypuft) MUST be able to PXE boot a node that Ceph will use and install RHELOSP RHEL7 operating system with all Ceph server library dependencies (for block, object, NAS (in priority order)),
setup networks (bonds, vLANs) per node type (storage node, controller node - see https://bugzilla.redhat.com/show_bug.cgi?id=1119874),
ability to specify host group separately for MON and OSD nodes (for network setup).
Ability to modify networks configuration for nodes that Ceph is using.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2014-07-23 17:58:24 UTC
Neil,
nobt sure if RHELOSP5 RHEL7 should include all Ceph libraries.
Then ICE will handle configuration and setup portion of Ceph deployment

Comment 3 Neil Levine 2014-07-24 02:40:15 UTC
ICE will install all the relevant Ceph components. There is no need for the RHEL-OSP Installer to do this.

[The RHEL-OSP Installer should only handle installing the Ceph client libraries on any Glancer/Cinder/Nova nodes as necessary.]

Also, my understanding (which could be wrong) is that Staypuft just refers to the UI. It is really Foreman that needs to do the heavy lifting for this BZ.

Comment 4 Mike Burns 2014-07-25 13:35:36 UTC
*** Bug 1122667 has been marked as a duplicate of this bug. ***

Comment 6 Mike Burns 2014-08-07 14:41:17 UTC
Initial effort:

New Ceph host group will be added that will do *only* base RHEL 7 provisioning

Comment 7 Mike Burns 2014-08-14 20:08:27 UTC
To elaborate on the initial effort:

2 new host groups will be added

Ceph Storage Node (OSD)
Generic RHEL 7

These will be exposed in the Assign Hosts screen and will allow network configuration, etc.  

The backend puppet classes used will be core RHEL 7 only. 

No Ceph Storage configuration will be done.  That is the domain of the ICE installer.

Comment 8 Brad P. Crochet 2014-08-22 16:53:13 UTC
PR submitted: https://github.com/theforeman/staypuft/pull/272

Comment 11 Summer Long 2014-09-26 01:35:30 UTC
Brad, could you double check the doc-text edit? Just want to ensure I understood your intent. thanks, Summer

Comment 12 arkady kanevsky 2014-09-26 13:25:26 UTC
Mike,
do we have a kickstart file specific to generic RHEL7 and to Ceph Node (OSD)?
Arkady

Comment 13 Mike Burns 2014-09-26 18:20:37 UTC
(In reply to arkady kanevsky from comment #12)
> Mike,
> do we have a kickstart file specific to generic RHEL7 and to Ceph Node (OSD)?
> Arkady

There is only 1 kickstart.  There will be (in the next release) a condition around the partitioning for ceph nodes, otherwise, it's the same kickstart.

Comment 14 Yogev Rabl 2014-09-28 12:27:49 UTC
verified in version ruby193-rubygem-staypuft-0.3.9-1.el6ost.noarch

The Staypuft has installed a clean RHEL 7. 
From what I understand this is the requirement at this stage of the installation.

Comment 16 errata-xmlrpc 2014-10-01 13:25:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html

Comment 17 Brad P. Crochet 2018-09-26 12:06:00 UTC
Clearing needinfo


Note You need to log in before you can comment on or make changes to this bug.