Bug 1122667 - [RFE] Staypuft should be able to setup node(s) as required for Ceph cluster (OSD and MON)
Summary: [RFE] Staypuft should be able to setup node(s) as required for Ceph cluster (...
Keywords:
Status: CLOSED DUPLICATE of bug 1122663
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 18:00 UTC by arkady kanevsky
Modified: 2014-09-08 05:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1122663
Environment:
Last Closed: 2014-07-25 13:35:36 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-23 18:00:31 UTC
+++ This bug was initially created as a clone of Bug #1122663 +++

Description of problem:
For Ceph cluster deployment OSP deployer (Staypuft) MUST be able to PXE boot a node that Ceph will use and install RHELOSP RHEL7 operating system with all Ceph server library dependencies (for block, object, NAS (in priority order)),
setup networks (bonds, vLANs) per node type (storage node, controller node - see https://bugzilla.redhat.com/show_bug.cgi?id=1119874),
ability to specify host group separately for MON and OSD nodes (for network setup).
Ability to modify networks configuration for nodes that Ceph is using.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from arkady kanevsky on 2014-07-23 13:58:24 EDT ---

Neil,
nobt sure if RHELOSP5 RHEL7 should include all Ceph libraries.
Then ICE will handle configuration and setup portion of Ceph deployment

Comment 2 Mike Burns 2014-07-25 13:35:36 UTC
The RHEL-OSP installer currently runs only on RHEL 6.  Changes made on RHEL 6 will apply to RHEL-OSP deployments on both RHEL 6 and RHEL 7.  Closing this bug as a duplicate since we only need to track it in 1 place.

*** This bug has been marked as a duplicate of bug 1122663 ***


Note You need to log in before you can comment on or make changes to this bug.