Bug 1122726 - staypuft: nic naming in discovery is different than in deployment (el6 vs el7)
Summary: staypuft: nic naming in discovery is different than in deployment (el6 vs el7)
Keywords:
Status: CLOSED DUPLICATE of bug 1124041
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1123393 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 22:26 UTC by Alexander Chuzhoy
Modified: 2014-08-08 12:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Currently, the Red Hat Enterprise Linux OpenStack Platform Installer requests specific NIC information in the wizard. This installer's discovery image provides some information about the NICs on a host, which will likely be different from the runtime state NIC names used by Red Hat Enterprise Linux 7. This is due to a network interface naming feature in Red Hat Enterprise Linux 7. However, the installer will require the actual runtime state NIC names used by Red Hat Enterprise Linux 7 when configuring the deployment. This information is available in Red Hat Enterprise Linux 7 from any host you plan to deploy Red Hat Enteprise Linux OpenStack Platform 5. If all your hosts are hardware equivalent, you should only need to do this for one host.
Clone Of:
Environment:
Last Closed: 2014-08-08 12:38:00 UTC


Attachments (Terms of Use)

Description Alexander Chuzhoy 2014-07-23 22:26:41 UTC
Rubygem-Staypuft:  Deployment of nonHA Neutron (VLAN) gets stuck on 60% installing the networker.


Environment: liveCD rhelosp-installer-live-6.5-20140722.0.iso
rhel-osp-installer-0.1.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-19.1.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch

Steps to reproduce:
1. install rhel-osp-installer on liveCD.2
2. Create/run a nonHA neutron deployment with VLAN tenant network type.
3. In Tenant (VM Data) VLAN Ranges field specify 10:100.

Result:
The deployment gets paused with error on 60% installing the networker.
The networker isn't accessible via network (and can't obviously reach the puppet server).

Expected result:
Successfully completed deployment.

Comment 2 Jason Guiditta 2014-07-23 22:58:04 UTC
To track the setup better, could you add 2 bits of information here?
1. yaml output of the failed host
2. did you check the "Configure external interface on network node" checkbox?

Comment 3 Alexander Chuzhoy 2014-07-24 15:59:47 UTC
Didn't check the button for configuring the external interface on network node.


yaml output:
---
classes:
  quickstack::neutron::networker:
    amqp_host: 192.168.0.12
    amqp_password: d49dc0a9d81b14260089da25486a7cc4
    amqp_provider: rabbitmq
    amqp_username: openstack
    controller_priv_host: 192.168.0.12
    enable_tunneling: 'false'
    external_network_bridge: br-ex
    fixed_network_range: ${$quickstack::params::fixed_network_range}
    mysql_ca: /etc/ipa/ca.crt
    mysql_host: 192.168.0.12
    neutron_db_password: aca57dc67fa679f8b81dd119436d550e
    neutron_metadata_proxy_secret: 44b2926fe4059c94f1512f74ba15eb4c
    neutron_user_password: 3c6a01e645d9cff17378dda734c68429
    nova_db_password: 1be34577527ba3da89a39ee93f9bb2dd
    nova_user_password: 6bf02653fb87b70dfa783ce5a9bac3cd
    ovs_bridge_mappings:
    - physnet-tenants:br-eth0
    ovs_bridge_uplinks:
    - br-eth0:eth0
    ovs_l2_population: 'True'
    ovs_tunnel_iface: ''
    ovs_tunnel_network: ''
    ovs_tunnel_types:
    - vxlan
    - gre
    ovs_vlan_ranges:
    - physnet-external
    ovs_vxlan_udp_port: '4789'
    ssl: 'false'
    tenant_network_type: vxlan
    tunnel_id_ranges: 1:1000
    verbose: 'true'
parameters:
  puppetmaster: staypuft.example.com
  domainname: Default domain used for provisioning
  hostgroup: base_RedHat_7/neutron-3-flat/Neutron Networker
  root_pw: $5$fm$EO4A.ybSB/ofUaZWkzNePd38XRpUQNXls8y1feWvIy3
  puppet_ca: staypuft.example.com
  foreman_env: production
  owner_name: Admin User
  owner_email: root@example.com
  ui::cinder::driver_backend: nfs
  ui::cinder::nfs_uri: 192.168.0.1:/cinder
  ui::deployment::amqp_provider: rabbitmq
  ui::deployment::layout_name: Controller / Compute
  ui::deployment::networking: neutron
  ui::deployment::platform: rhel7
  ui::glance::driver_backend: local
  ui::neutron::compute_tenant_interface: eth0
  ui::neutron::networker_tenant_interface: eth0
  ui::neutron::network_segmentation: flat
  ui::neutron::use_external_interface: 'false'
  ui::nova::network_manager: FlatDHCPManager
  ui::passwords::admin: b8f366e57292c13302d4891058c116bc
  ui::passwords::amqp: d49dc0a9d81b14260089da25486a7cc4
  ui::passwords::amqp_nssdb: 217329ee42fbb45b9716a4682ec006b1
  ui::passwords::ceilometer_metering_secret: 9d3e84fdf74dca3bae79ecbb678ee809
  ui::passwords::ceilometer_user: 9cac73643ffde9c3445ff7f764fa4422
  ui::passwords::cinder_db: 5e6c6df6ac3a65431335c905a1889dc2
  ui::passwords::cinder_user: 5db2a53ded8c2cf6cbf19adb3ed8424d
  ui::passwords::glance_db: 165e41d52b032769283443dacb55cba3
  ui::passwords::glance_user: 45a0bcfeb9c5452a8962f7c659f520ac
  ui::passwords::heat_auth_encrypt_key: 2eaf91cd04be0c2be085a312c3500796
  ui::passwords::heat_cfn_user: 901b87acdc8f9be05534bda0401ce071
  ui::passwords::heat_db: 94bd5ae92942fbca2b490f198f2f8546
  ui::passwords::heat_user: 430fbe15f789f9c12f8e6f8302b56d0e
  ui::passwords::horizon_secret_key: 6a061099cde0190dd79b5ff1f6be058a
  ui::passwords::keystone_admin_token: 777ff2f8f0e6d65393166c2e4202810e
  ui::passwords::keystone_db: 0b5af439dd6da54ea724309a27d3d02b
  ui::passwords::keystone_user: fbf2097bf835a6c702a15698810c1369
  ui::passwords::mode: random
  ui::passwords::mysql_root: 1a7ca0d9e80ab3f16394b9b03d73b97e
  ui::passwords::neutron_db: aca57dc67fa679f8b81dd119436d550e
  ui::passwords::neutron_metadata_proxy_secret: 44b2926fe4059c94f1512f74ba15eb4c
  ui::passwords::neutron_user: 3c6a01e645d9cff17378dda734c68429
  ui::passwords::nova_db: 1be34577527ba3da89a39ee93f9bb2dd
  ui::passwords::nova_user: 6bf02653fb87b70dfa783ce5a9bac3cd
  ui::passwords::swift_admin: f3a0d7d2ee9cbbe8547b35b392a9023c
  ui::passwords::swift_shared_secret: 43c99884870a8ab82e4d64a153d92304
  ui::passwords::swift_user: a2cb97f73a2f77bda014965f3333b4fd
environment: production

Comment 4 Mike Burns 2014-07-25 21:28:58 UTC
This is due to incorrect nic names provided.  Provided eth0, host got ens7

Comment 5 Mike Burns 2014-07-28 17:00:03 UTC
defer to ga3 and add release note.

Comment 9 Mike Burns 2014-08-05 18:16:17 UTC
*** Bug 1123393 has been marked as a duplicate of this bug. ***

Comment 11 Mike Burns 2014-08-08 12:37:46 UTC
Despite being older, this is a duplicate of bug 1124041 which has additional details and is being worked on elsewhere

Comment 12 Mike Burns 2014-08-08 12:38:00 UTC

*** This bug has been marked as a duplicate of bug 1124041 ***


Note You need to log in before you can comment on or make changes to this bug.