Bug 1124041 - RFE: need to rebase discovery image on el7
Summary: RFE: need to rebase discovery image on el7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman-discovery-image
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z1
: Installer
Assignee: Lukas Zapletal
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1122726 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 21:10 UTC by Mike Burns
Modified: 2014-10-01 13:25 UTC (History)
8 users (show)

Fixed In Version: foreman-discovery-image-7.0-20140822.0.el7sat
Doc Type: Enhancement
Doc Text:
The foreman discovery image is now based on Red Hat Enterprise Linux 7.0 which leads to better hardware support and faster starts.
Clone Of:
Environment:
Last Closed: 2014-10-01 13:25:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Mike Burns 2014-07-28 21:10:43 UTC
Description of problem:
The current foreman discovery image is based on RHEL 6 components.  This can lead to some inconsistencies with the facts of the machine when deploying RHEL OSP onto RHEL 7.  Namely the network interfaces have different default naming in RHEL 6 and RHEL 7.  

Having a rhel 7 based discovery image would dramatically ease some of the deployment issues.

Comment 2 Mike Burns 2014-08-08 12:38:00 UTC
*** Bug 1122726 has been marked as a duplicate of this bug. ***

Comment 8 Mike Burns 2014-08-27 18:33:03 UTC
Move to A1 based on bug 1133579

Comment 10 Omri Hochman 2014-09-15 06:31:41 UTC
Verified with :

foreman-discovery-image-7.0-20140905.0.2.el7sat.noarch  
rhel-osp-installer-0.3.4-3.el6ost.noarch

- The discovery image is now based on EL7 - when it boot the NIC names that displays shows the correct NIC names that will also be after the machine is being provision.

Comment 12 errata-xmlrpc 2014-10-01 13:25:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.