Bug 1122917 - Kdump default target doesn't work in node
Summary: Kdump default target doesn't work in node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: bugs@ovirt.org
URL:
Whiteboard: node
Depends On:
Blocks: 1123413
TreeView+ depends on / blocked
 
Reported: 2014-07-24 11:59 UTC by Martin Perina
Modified: 2016-02-10 19:39 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1123413 (view as bug list)
Environment:
Last Closed: 2014-10-17 12:41:57 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30705 master MERGED Always use local kdump after install installs Never
oVirt gerrit 31052 ovirt-3.5 ABANDONED Always use local kdump after install installs Never

Description Martin Perina 2014-07-24 11:59:57 UTC
Description of problem:

By default in /etc/kdump.conf kdump target is set to /var/crash. But this default doesn't work in Node and when you try to start kdump service, following error appears:

  # service kdump start
  No kdump initial ramdisk found.[WARNING]
  Rebuilding /boot-kdump/initrd-2.6.32-431.20.3.el6.x86_64kdump.img
  mount: /dev/mapper/live-rw already mounted or /tmp/tmp.WCE4ysGYog busy
  mount: according to mtab, /dev/mapper/live-rw is mounted on /
  /etc/kdump.conf: Bad mount point UUID=ae24299b-205f-4434-89ad-c1e5f2a222e6
  Failed to run mkdumprd

This behavior breaks compatibility with kdump behavior on Fedora/RHEL/Centos, where local crashdump is set correctly by default. It also forces sysadmin:

  1. Select NFS as kdump target using kdump_nfs kernel command line parameter or

  2. Login to host and use UI to configure kdump target.


Version-Release number of selected component (if applicable):

ovirt-node-iso-3.5.0.ovirt35.20140707.el6

How reproducible:


Steps to Reproduce:
1. Install node with default boot parameters (without kdump_nfs)
2. Login as root and try to start kdump service


Actual results:

Kdump service cannot be started due to error mentioned above

Expected results:

Kdump service can be started with default target after installation

Additional info:

There are several options how to solve this:

1. Provide /etc/kdump.conf with working local kdump target by default (this is the best idea IMO)

2. Provide kernel boot parameter to configure local kdump target on installation

Comment 1 Ryan Barry 2014-07-24 18:25:17 UTC
Martin:

kdump_local=y should already work for autoinstalls.

We can ship a kdump config which matches the configuration set if you configure it through the TUI, though to be clear, it will not work during the install itself. Will that work?

Comment 2 Martin Perina 2014-07-25 12:57:23 UTC
Thanks Ryan, I didn't know about kdump_local parameter, because the only documentation describing node specific kernel command line parameters I found was RHEVH 3.2 Hypervisor deployment guide :-( and there's only kdump_nfs param.

Anyway I just tested kdump_local parameter and it works fine. If this parameter was specified during installation, once installation finishes, host can be added to oVirt using host deploy without any manual intervention, so that's great.

Now, is it possible to make this parameter to be enabled by default? I mean when sysadmin prepares PXE setup, he wouldn't need to add this param manually.

Comment 3 Ryan Barry 2014-07-25 15:44:56 UTC
A patch is up to enable it by default, and add a parameter (disable_kdump) which flags kdump off at install.

Comment 4 Sandro Bonazzola 2014-10-17 12:41:57 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.