Bug 1123413 - Kdump default target doesn't work in node
Summary: Kdump default target doesn't work in node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1122917
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 14:41 UTC by Martin Perina
Modified: 2016-02-10 20:11 UTC (History)
18 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Bug Fix
Doc Text:
Previously, kdump was not started on boot and prevented the kdump fencing feature from working on the Red Hat Enterprise Virtualization Hypervisor. Now, kdump is started by default and works with the Hypervisor as expected.
Clone Of: 1122917
Environment:
Last Closed: 2015-02-11 21:00:43 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30705 master MERGED Always use local kdump after install installs Never
oVirt gerrit 31052 ovirt-3.5 ABANDONED Always use local kdump after install installs Never

Description Martin Perina 2014-07-25 14:41:19 UTC
+++ This bug was initially created as a clone of Bug #1122917 +++

Description of problem:

By default in /etc/kdump.conf kdump target is set to /var/crash. But this default doesn't work in Node and when you try to start kdump service, following error appears:

  # service kdump start
  No kdump initial ramdisk found.[WARNING]
  Rebuilding /boot-kdump/initrd-2.6.32-431.20.3.el6.x86_64kdump.img
  mount: /dev/mapper/live-rw already mounted or /tmp/tmp.WCE4ysGYog busy
  mount: according to mtab, /dev/mapper/live-rw is mounted on /
  /etc/kdump.conf: Bad mount point UUID=ae24299b-205f-4434-89ad-c1e5f2a222e6
  Failed to run mkdumprd

This behavior breaks compatibility with kdump behavior on Fedora/RHEL/Centos, where local crashdump is set correctly by default. It also forces sysadmin:

  1. Select NFS as kdump target using kdump_nfs kernel command line parameter or

  2. Login to host and use UI to configure kdump target.


Version-Release number of selected component (if applicable):

ovirt-node-iso-3.5.0.ovirt35.20140707.el6

How reproducible:


Steps to Reproduce:
1. Install node with default boot parameters (without kdump_nfs)
2. Login as root and try to start kdump service


Actual results:

Kdump service cannot be started due to error mentioned above

Expected results:

Kdump service can be started with default target after installation

Additional info:

There are several options how to solve this:

1. Provide /etc/kdump.conf with working local kdump target by default (this is the best idea IMO)

2. Provide kernel boot parameter to configure local kdump target on installation

--- Additional comment from Ryan Barry on 2014-07-24 14:25:17 EDT ---

Martin:

kdump_local=y should already work for autoinstalls.

We can ship a kdump config which matches the configuration set if you configure it through the TUI, though to be clear, it will not work during the install itself. Will that work?

--- Additional comment from Martin Perina on 2014-07-25 08:57:23 EDT ---

Thanks Ryan, I didn't know about kdump_local parameter, because the only documentation describing node specific kernel command line parameters I found was RHEVH 3.2 Hypervisor deployment guide :-( and there's only kdump_nfs param.

Anyway I just tested kdump_local parameter and it works fine. If this parameter was specified during installation, once installation finishes, host can be added to oVirt using host deploy without any manual intervention, so that's great.

Now, is it possible to make this parameter to be enabled by default? I mean when sysadmin prepares PXE setup, he wouldn't need to add this param manually.

Comment 1 cshao 2014-08-06 08:50:45 UTC
RHEV-H QE can reproduce this issue.

Test version:
ovirt-node-iso-3.5.0.ovirt35.20140707.el6.iso
ovirt-node-3.1.0-0.0.master.20140707.git2f40d75.el6.noarch

Test steps:
1. auto install with below parameters:
BOOTIF=eth0 storage_init=/dev/sda adminpw=XXXXXXX firstboot

2. Enter TUI
3. # service kdump start

Test result:
  No kdump initial ramdisk found.[WARNING]
  Rebuilding /boot-kdump/initrd-2.6.32-431.20.3.el6.x86_64kdump.img
  mount: /dev/mapper/live-rw already mounted or /tmp/tmp.WCE4ysGYog busy
  mount: according to mtab, /dev/mapper/live-rw is mounted on /
  /etc/kdump.conf: Bad mount point UUID=xxxxxxxx
  Failed to run mkdumprd

NOTE:
No such issue if auto install with kdump_nfs=xxx parameters.
TUI install no such issue.

Comment 2 cshao 2015-01-14 07:46:21 UTC
Test version:
rhev-hypervisor6-6.6-20150112.0
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el6.noarch

Test steps:
1. auto install with below parameters:
BOOTIF=eth0 storage_init=/dev/sda adminpw=XXXXXXX firstboot
2. Enter TUI, press F2 enter cmd.
3. # service kdump start
4. TUI install rhevh and check kdump.

Test result:
# service kdump start
Kdump already running      

1. Auto: Kdump default target can work fine.
2. TUI: Kdump default target can work fine.

So the bug has been fixed, change bug status to VERIFIED.

Comment 4 errata-xmlrpc 2015-02-11 21:00:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.