Bug 1122918 - [packaging] ovirt-engine doesn't depend on log-collector as d/s does
Summary: [packaging] ovirt-engine doesn't depend on log-collector as d/s does
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 12:00 UTC by Jiri Belka
Modified: 2015-08-11 19:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 09:04:23 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1103876 None None None Never

Internal Links: 1103876

Description Jiri Belka 2014-07-24 12:00:32 UTC
Description of problem:
ovirt-engine doesn't depend on log-collector as d/s does.

without log-collector all will face _poor_ bug reports and spend time asking reporter for more details :)

d/s:

# rpm -qR rhevm | grep log
rhevm-log-collector >= 3.4.0

u/s:

# rpm -qR ovirt-engine
/bin/sh  
/bin/sh  
/bin/sh  
config(ovirt-engine) = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
fop  
java  
java-1.7.0-openjdk >= 1:1.7.0.9-2.3.3.2
jpackage-utils  
ovirt-engine-backend = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-cli  
ovirt-engine-dbscripts = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-jboss-as >= 7.1.1
ovirt-engine-restapi = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-setup >= 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-tools = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-userportal = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-webadmin-portal = 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-engine-websocket-proxy >= 3.5.0-0.0.master.20140715172116.git4687dc1.el6
ovirt-image-uploader >= 3.5.0
ovirt-iso-uploader >= 3.5.0
patternfly1  
postgresql-server >= 8.4.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
ws-commons-util  
yum-plugin-versionlock  
rpmlib(PayloadIsXz) <= 5.2-1

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. install ovirt-engine
2. rpm -qa | grep ovirt-log-collector
3.

Actual results:
not present

Expected results:
should be installed (d/s does it)

Additional info:

Comment 1 Petr Beňas 2014-08-05 11:36:02 UTC
Our logcolletor test fails since the logcollector is not installed as a depencency of the engine.

Comment 2 Sandro Bonazzola 2014-08-08 09:04:23 UTC
As per bug #1103876 ovirt-log-collector is not a mandatory dependency for ovirt-engine since oVirt 3.4.3.
Please update your test automation for installing ovirt-log-collector before starting the test.


Note You need to log in before you can comment on or make changes to this bug.