Bug 1122971 - ISE in case no system is selected for deployed configuration files comparison.
Summary: ISE in case no system is selected for deployed configuration files comparison.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 580
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
: 1395885 (view as bug list)
Depends On:
Blocks: sat560-triage 1122974 sat580-low 1395885
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:43 UTC by Dimitar Yordanov
Modified: 2017-06-21 12:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1122974 (view as bug list)
Environment:
Last Closed: 2017-06-21 12:09:34 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2014-07-24 13:43:50 UTC
Description of problem:
ISE in case no system  is selected for deployed configuration files comparison.

Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-78

How reproducible:
100%

Steps to Reproduce:
1. Create configuration channel.
2. Create a configuration file in it.
3. Register a client to Satellite.
     - add provisioning entitlement.
     - assign the configuration channel to the client.
     - install rhncfg* on the client.
4. Deploy the configuration file on the client.
    $ rhncfg-client get
5. Configuration -> Recently Modified Configuration Files: -> "conf file" ->
     Compare File -> Deployed Files
   Do not select any system, just press "Schedule File Comparison"

Actual results:
ISE

Expected results:
Some message.

Additional info:

Comment 1 Grant Gainey 2016-02-03 20:07:43 UTC
spacewalk.github PR#128

Comment 2 Grant Gainey 2016-02-04 19:38:38 UTC
spacewalk.github 70291fb1453e235fecfcc74e1e0f0854ff5a8df6q

Comment 3 Grant Gainey 2016-11-03 17:50:51 UTC
#c2 has incorrect -
spacewalk.github commit 70291fb1453e235fecfcc74e1e0f0854ff5a8df6

Comment 5 Jan Hutař 2016-11-22 08:52:02 UTC
*** Bug 1395885 has been marked as a duplicate of this bug. ***

Comment 6 Lukáš Hellebrandt 2017-04-26 11:16:37 UTC
Verified with spacewalk-java-2.5.14-73.el6sat.noarch .

Used reproducer from OP. Upon clicking "Schedule File Comparison", the same page is now loaded with warning "No system was selected.".


Note You need to log in before you can comment on or make changes to this bug.