Bug 1122974 - ISE in case no system is selected for deployed configuration files comparison.
Summary: ISE in case no system is selected for deployed configuration files comparison.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 2.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On: 1122971
Blocks: sat560-triage 1395885 space27
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:45 UTC by Dimitar Yordanov
Modified: 2017-09-27 18:56 UTC (History)
5 users (show)

Fixed In Version: spacewalk-java-2.5.48-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1122971
: 1395885 (view as bug list)
Environment:
Last Closed: 2017-09-27 18:56:59 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2014-07-24 13:45:10 UTC
+++ This bug was initially created as a clone of Bug #1122971 +++

Description of problem:
ISE in case no system  is selected for deployed configuration files comparison.

Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-78

How reproducible:
100%

Steps to Reproduce:
1. Create configuration channel.
2. Create a configuration file in it.
3. Register a client to Satellite.
     - add provisioning entitlement.
     - assign the configuration channel to the client.
     - install rhncfg* on the client.
4. Deploy the configuration file on the client.
    $ rhncfg-client get
5. Configuration -> Recently Modified Configuration Files: -> "conf file" ->
     Compare File -> Deployed Files
   Do not select any system, just press "Schedule File Comparison"

Actual results:
ISE

Expected results:
Some message.

Additional info:

Comment 1 Grant Gainey 2016-02-03 20:07:48 UTC
spacewalk.github PR#128

Comment 2 Grant Gainey 2016-02-04 19:37:57 UTC
spacewalk.github 70291fb1453e235fecfcc74e1e0f0854ff5a8df6q

Comment 3 Jan Hutař 2016-11-10 22:32:52 UTC
I have tested on both SWnightly@OracleXE10@RHEL6 and SWnightly@PostgreSQL@RHEL7 (spacewalk-java-2.6.47-1.el?.noarch).

When testing this, I have reported bug 1394053 and bug 1394058.

After performing steps in comment #0, I got "No system was selected." error, which is good. For sanity purposes, I have also tried to schedule the diff with one system selected and it worked. => VERIFIED

Comment 4 Eric Herget 2017-09-27 18:56:59 UTC
Spacewalk 2.7 has been released.

https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes27


Note You need to log in before you can comment on or make changes to this bug.