Bug 1123112 - qtconfig-qt4 depends on GStreamer 0.10
Summary: qtconfig-qt4 depends on GStreamer 0.10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: KDE-GStreamer1
TreeView+ depends on / blocked
 
Reported: 2014-07-24 22:18 UTC by Kevin Kofler
Modified: 2014-10-20 14:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 14:12:57 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2014-07-24 22:18:37 UTC
Description of problem:
qtconfig-qt4 (qt-config subpackage) has a tab for Phonon configuration, allowing to configure the Phonon GStreamer 0.10 backend. This also depends directly on GStreamer 0.10, to enumerate audio sinks and video rendering modes. With phonon-backend-gstreamer having switched to GStreamer 1, this tab is obsolete.

The easiest solution is to build qtconfig-qt4 without Phonon support. There is no port to GStreamer 1 available, and there is unlikely to ever be one because upstream dropped support for qtconfig in Qt 5 (see https://bugreports.qt-project.org/browse/QTBUG-32250).

Version-Release number of selected component (if applicable):
qt-config-4.8.6-10.fc22

How reproducible:
Always

Steps to Reproduce:
1. repoquery --repoid=rawhide --requires qt-config

Actual results:
Contains GStreamer 0.10 libraries:
libgstbase-0.10.so.0
libgstinterfaces-0.10.so.0
libgstreamer-0.10.so.0
libgstvideo-0.10.so.0

Expected results:
Does not contain those libraries.

Additional info:
This is basically the opposite of the old bug #503260.

Comment 1 Kevin Kofler 2014-08-12 22:18:23 UTC
I'm taking this (building Qt without the bundled Phonon entirely, which gets us rid of the GStreamer 0.10 use in qtconfig-qt4, on F21+ and adding phonon.prl to phonon-devel where it belongs).

Comment 2 Kevin Kofler 2014-08-12 23:40:24 UTC
I built Qt without Phonon in Rawhide. We need to check whether QMake-based stuff using QT+=phonon still works, and if not, what needs to be changed (e.g., do we need to add libphonon.prl to phonon-devel? I now think it might actually not be needed).

Comment 3 Rex Dieter 2014-10-20 14:12:57 UTC
qt-4.8.6-11 landed for awhile, closing.


Note You need to log in before you can comment on or make changes to this bug.