Bug 1123171 - Backport CoW with RBD for ephemeral volumes
Summary: Backport CoW with RBD for ephemeral volumes
Keywords:
Status: CLOSED DUPLICATE of bug 1062022
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 6.0 (Juno)
Assignee: Pádraig Brady
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1163445
TreeView+ depends on / blocked
 
Reported: 2014-07-25 04:22 UTC by Neil Levine
Modified: 2019-09-09 15:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-04 13:01:24 UTC


Attachments (Terms of Use)

Description Neil Levine 2014-07-25 04:22:17 UTC
Description of problem:

The following code was merged upstream to enable CoW cloning for ephemeral volumes backed by RBD:

https://review.openstack.org/91486

This is the last remaining big piece to allow 'diskless' compute nodes with all of their VM storage backed by Ceph.

Having this backported to RHEL-OSP5 has been demanded by various customers.

Comment 2 arkady kanevsky 2014-07-25 13:29:59 UTC
Not a blocker for joint solution GA release.

Comment 4 Pádraig Brady 2014-12-04 13:01:24 UTC

*** This bug has been marked as a duplicate of bug 1062022 ***


Note You need to log in before you can comment on or make changes to this bug.