Bug 1123299 - smbios table 0 vendor string should be Seabios (for rhel6 compatibility) [7.1+7.0.z]
Summary: smbios table 0 vendor string should be Seabios (for rhel6 compatibility) [7.1...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard: integration
Depends On:
Blocks: 1030037 1123838 1124216
TreeView+ depends on / blocked
 
Reported: 2014-07-25 09:18 UTC by Gerd Hoffmann
Modified: 2015-03-05 08:15 UTC (History)
26 users (show)

Fixed In Version: seabios-1.7.5-3.el7
Doc Type: Bug Fix
Doc Text:
Previously, SeaBIOS for Red Hat Enterprise Linux 7 filled vendor and version fields with upstream values that differed from ones used in Red Hat Enterprise Linux 6. This could cause issues when guest was migrated from version 6 to 7. With this fix, proper values are used, which do not change after migration.
Clone Of: 1030037
: 1123838 1124216 (view as bug list)
Environment:
Last Closed: 2015-03-05 08:15:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0345 normal SHIPPED_LIVE seabios bug fix and enhancement update 2015-03-05 12:27:47 UTC

Comment 1 Gerd Hoffmann 2014-07-25 09:25:24 UTC
rhel6/seabios commit 1389643dad35a63362cd7d8357693f01175ef473

Comment 4 Andrew Cathrow 2014-07-27 11:26:55 UTC
Added z-stream flag.

Comment 5 Gerd Hoffmann 2014-07-28 12:02:15 UTC
Created separate z-stream bug 1123838 (different seabios versions, different patches).

Comment 6 Gerd Hoffmann 2014-07-28 12:14:46 UTC
Patches posted.

Comment 7 Gerd Hoffmann 2014-07-28 13:04:52 UTC
Hmm, separate zstream bug has been outlawed ...

Comment 10 Miroslav Rezanina 2014-08-13 06:22:14 UTC
Fix included in seabios-1.7.5-3.el7

Comment 12 huiqingding 2014-11-06 05:02:26 UTC
Reproduce this bug using the following version:
qemu-kvm-1.5.3-60.el7.x86_64
kernel-3.10.0-196.el7.x86_64
seabios-bin-1.7.2.2-12.el7.x86_64
rhev-guest-tools-iso-3.5-6.el6ev.noarch

Steps to Reproduce:
1. Boot a  Windows XP Sp3 guest
/usr/libexec/qemu-kvm -M pc -cpu SandyBridge,+x2apic,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time -enable-kvm -m 4096 -smp 4,sockets=2,cores=2,threads=1,maxcpus=160 -name rhel7 -rtc base=localtime,clock=host,driftfix=slew  -device virtio-serial-pci,id=virtio-serial0 -chardev socket,id=channel1,path=/tmp/test1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.com,bus=virtio-serial0.0,id=port1  -drive file=/home/winxpsp3-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,id=virtio-disk -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -serial unix:/tmp/ttyS0,server,nowait -spice port=5900,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -monitor stdio -qmp tcp:0:4445,server,nowait -nodefaults -boot menu=on -cdrom en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -drive file=/usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.5_6.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0,logical_block_size=512,physical_block_size=512,min_io_size=32,opt_io_size=64,discard_granularity=512,unit=1,ver=fuxc-ver-cdrom,bus=ide.0,unit=1

2. insatll rhev-guest-tools
inside the guest, click "RHEV-toolSetup" of CDROM to install rhev-guest-tools

Actual results:
after step2, rhev-guest-tools cannot be installed with the abort dialog box appears "Installation of RHEV-Tools on the Guest should be performed only when running on RHEL 6 type Host (RHEV-H or RHEL). Installation aorted."

Comment 13 huiqingding 2014-11-06 05:08:35 UTC
Test this bug on an intel host using the following version:
qemu-kvm-rhev-2.1.2-6.el7.x86_64
kernel-3.10.0-196.el7.x86_64
seabios-bin-1.7.5-5.el7.noarch
rhev-guest-tools-iso-3.5-6.el6ev.noarch

Steps to Test:
1. Boot a  Windows XP Sp3 guest
/usr/libexec/qemu-kvm -M pc -cpu SandyBridge,+x2apic,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time -enable-kvm -m 4096 -smp 4,sockets=2,cores=2,threads=1,maxcpus=160 -name rhel7 -rtc base=localtime,clock=host,driftfix=slew  -device virtio-serial-pci,id=virtio-serial0 -chardev socket,id=channel1,path=/tmp/test1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.com,bus=virtio-serial0.0,id=port1  -drive file=/home/winxpsp3-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,id=virtio-disk -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -serial unix:/tmp/ttyS0,server,nowait -spice port=5900,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -monitor stdio -qmp tcp:0:4445,server,nowait -nodefaults -boot menu=on -cdrom en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -drive file=/usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.5_6.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0,logical_block_size=512,physical_block_size=512,min_io_size=32,opt_io_size=64,discard_granularity=512,unit=1,ver=fuxc-ver-cdrom,bus=ide.0,unit=1

2. insatll rhev-guest-tools
inside the guest, click "RHEV-toolSetup" of CDROM to install rhev-guest-tools

Actual results:
after step2, rhev-guest-tools cannot be installed normally.

Comment 14 huiqingding 2014-11-06 05:54:53 UTC
Test this bug on an amd host using the following version:
qemu-kvm-1.5.3-77.el7.x86_64
kernel-3.10.0-195.el7.x86_64
seabios-bin-1.7.5-5.el7.noarch
rhev-guest-tools-iso-3.5-6.el6ev.noarch

Steps to Test:
1. Boot a  Windows XP Sp3 guest
/usr/libexec/qemu-kvm -M pc -cpu Opteron_G2,+x2apic,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time -enable-kvm -m 4096 -smp 4,sockets=2,cores=2,threads=1,maxcpus=160 -name rhel7 -rtc base=localtime,clock=host,driftfix=slew  -device virtio-serial-pci,id=virtio-serial0 -chardev socket,id=channel1,path=/tmp/test1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.com,bus=virtio-serial0.0,id=port1  -drive file=/home/winxpsp3-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,id=virtio-disk -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -serial unix:/tmp/ttyS0,server,nowait -spice port=5900,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -monitor stdio -qmp tcp:0:4445,server,nowait -nodefaults -boot menu=on -cdrom en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -drive file=/usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.5_6.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0,logical_block_size=512,physical_block_size=512,min_io_size=32,opt_io_size=64,discard_granularity=512,unit=1,ver=fuxc-ver-cdrom,bus=ide.0,unit=1

2. insatll rhev-guest-tools
inside the guest, click "RHEV-toolSetup" of CDROM to install rhev-guest-tools

Actual results:
after step2, rhev-guest-tools cannot be installed normally.

Comment 17 errata-xmlrpc 2015-03-05 08:15:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0345.html


Note You need to log in before you can comment on or make changes to this bug.