Bug 1124216 - smbios table 0 vendor string should be Seabios (for rhel6 compatibility) [7.1+7.0.z]
Summary: smbios table 0 vendor string should be Seabios (for rhel6 compatibility) [7.1...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1123299
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 06:57 UTC by Jan Kurik
Modified: 2014-08-25 09:30 UTC (History)
29 users (show)

Fixed In Version: seabios-1.7.2.2-12.el7_0.1
Doc Type: Bug Fix
Doc Text:
Previously, SeaBIOS for Red Hat Enterprise Linux 7 filled vendor and version fields with upstream values that differed from ones used in Red Hat Enterprise Linux 6. This could cause issues when guest was migrated from version 6 to 7. With this fix, proper values are used, which do not change after migration.
Clone Of: 1123299
Environment:
Last Closed: 2014-08-25 09:30:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1092 normal SHIPPED_LIVE seabios bug fix update 2014-08-25 13:30:40 UTC

Description Jan Kurik 2014-07-29 06:57:35 UTC
This bug has been copied from bug #1123299 and has been proposed
to be backported to 7.0 z-stream (EUS).

Comment 5 Miroslav Rezanina 2014-08-13 07:31:34 UTC
Fix included in seabios-1.7.2.2-12.el7_0.1

Comment 7 Sibiao Luo 2014-08-18 05:23:27 UTC
Reproduce this issue on seabios-1.7.2.2-12.el7.x86_64.
host info:
# uname -r && rpm -q qemu-kvm && rpm -q seabios
3.10.0-128.el7.x86_64
qemu-kvm-1.5.3-67.el7.x86_64
seabios-1.7.2.2-12.el7.x86_64

# dmidecode -t 0
# dmidecode 2.12
SMBIOS 2.4 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: Bochs           <--------------
	Version: Bochs          <--------------
	Release Date: 01/01/2011
	Address: 0xE8000
	Runtime Size: 96 kB
	ROM Size: 64 kB
	Characteristics:
		BIOS characteristics not supported
		Targeted content distribution is supported
	BIOS Revision: 1.0
# dmidecode -t 1
# dmidecode 2.12
SMBIOS 2.4 present.

Handle 0x0100, DMI type 1, 27 bytes
System Information
	Manufacturer: Red Hat
	Product Name: KVM
	Version: RHEL 7.0.0 PC (i440FX + PIIX, 1996)
	Serial Number: Not Specified
	UUID: 990EA161-6B67-47B2-B803-19FB01D30D30
	Wake-up Type: Power Switch
	SKU Number: Not Specified
	Family: Red Hat Enterprise Linux

#########################################################

Verified this issue on seabios-1.7.2.2-12.el7_0.1.x86_64.
host info:
# uname -r && rpm -q qemu-kvm && rpm -q seabios
3.10.0-128.el7.x86_64
qemu-kvm-1.5.3-67.el7.x86_64
seabios-1.7.2.2-12.el7_0.1.x86_64

# dmidecode -t 0
# dmidecode 2.12
SMBIOS 2.4 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: Seabios           <--------------
	Version: 0.5.1            <--------------
	Release Date: 01/01/2011
	Address: 0xE8000
	Runtime Size: 96 kB
	ROM Size: 64 kB
	Characteristics:
		BIOS characteristics not supported
		Targeted content distribution is supported
	BIOS Revision: 1.0

# dmidecode -t 1
# dmidecode 2.12
SMBIOS 2.4 present.

Handle 0x0100, DMI type 1, 27 bytes
System Information
	Manufacturer: Red Hat
	Product Name: KVM
	Version: RHEL 7.0.0 PC (i440FX + PIIX, 1996)
	Serial Number: Not Specified
	UUID: 990EA161-6B67-47B2-B803-19FB01D30D30
	Wake-up Type: Power Switch
	SKU Number: Not Specified
	Family: Red Hat Enterprise Linux

Base on above, this issue has been fixed correctly, move to VERIFIED status.

Best Regards,
sluo

Comment 9 Mike Cao 2014-08-18 05:57:12 UTC
pls verify this bug on windows guest as well (check msinfo32.exe)

Comment 10 Sibiao Luo 2014-08-18 08:39:43 UTC
(In reply to Mike Cao from comment #9)
> pls verify this bug on windows guest as well (check msinfo32.exe)

Use "msinfo32" or "systeminfo" command just can check the BIOS Version/Date.
host info:
host info:
# uname -r && rpm -q qemu-kvm && rpm -q seabios
3.10.0-128.el7.x86_64
qemu-kvm-1.5.3-67.el7.x86_64
seabios-1.7.2.2-12.el7_0.1.x86_64
guest info:
Win7 64bit

Results:
BIOS Version: Seabios 0.5.1, 1/1/2011

Best Regards,
sluo.

Comment 14 errata-xmlrpc 2014-08-25 09:30:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1092.html


Note You need to log in before you can comment on or make changes to this bug.