Bug 1123414 - Kdump configuration in UI overwrite whole /etc/kdump.conf
Summary: Kdump configuration in UI overwrite whole /etc/kdump.conf
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.4
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1122923 1175854
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 14:43 UTC by Martin Perina
Modified: 2016-02-10 20:05 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1122923
Environment:
Last Closed: 2015-04-30 08:34:15 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30933 None None None Never

Description Martin Perina 2014-07-25 14:43:09 UTC
+++ This bug was initially created as a clone of Bug #1122923 +++

Description of problem:

When kdump configuration is updated using UI, the whole file is overwritten, so custom changes, which are impossible to change using UI, are lost. This behavior breaks kdump integration feature in oVirt 3.5, which sets those custom options during host deploy.

Version-Release number of selected component (if applicable):

ovirt-node-iso-3.5.0.ovirt35.20140707.el6

How reproducible:

100%

Steps to Reproduce:
1. Login as root, add custom changes to /etc/kdump.conf and restart kdump service so these changes are applied:

  default reboot
  ext4 /dev/HostVG/Data
  path /core
  fence_kdump_nodes mperina.brq.redhat.com
  fence_kdump_args -p 7410 -i 5


2. Login as admin and change settings kdump settings using UI (for example change kdump target to NFS)


3. Login as root and check content of /etc/kdump.conf


Actual results:

Content of /etc/kdump.conf after step 3.:

  default reboot
  nfs str-02.rhev.lab.eng.brq.redhat.com:/mnt/export/nfs/170/nfs04

Expected results:

Content of /etc/kdump.conf after step 3. when bug fixed:

  default reboot
  nfs str-02.rhev.lab.eng.brq.redhat.com:/mnt/export/nfs/170/nfs04
  fence_kdump_nodes mperina.brq.redhat.com
  fence_kdump_args -p 7410 -i 5


Additional info:

Comment 1 cshao 2014-08-05 10:25:03 UTC
RHEV-H QE can reproduce this issue.

Test version:
ovirt-node-iso-3.5.0.ovirt35.20140707.el6.iso
ovirt-node-3.1.0-0.0.master.20140707.git2f40d75.el6.noarch

Test steps:
1. Login as root, add custom changes to /etc/kdump.conf and restart kdump service so these changes are applied:

  default reboot
  ext4 /dev/HostVG/Data
  path /core
  fence_kdump_nodes mperina.brq.redhat.com
  fence_kdump_args -p 7410 -i 5

2. Login as admin and change settings kdump settings using UI to nfs
3. Login as root and check content of /etc/kdump.conf

The test result same as above.

Comment 2 haiyang,dong 2014-12-18 11:46:58 UTC
Test version:
rhev-hypervisor6-6.6-20141212.0.iso(RHEV-H 6.6 for RHEV3.5)
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

rhev-hypervisor7-7.0-20141212.0.iso(RHEV-H 7.0 for RHEV3.5)
ovirt-node-3.1.0-0.34.20141210git0c9c493.el7.noarch


Test steps:
1. Login as root, add custom changes to /etc/kdump.conf and restart kdump service so these changes are applied:

  default reboot
  ext4 /dev/HostVG/Data
  path /core
  fence_kdump_nodes mperina.brq.redhat.com
  fence_kdump_args -p 7410 -i 5

2. Login as admin and change settings kdump settings using UI to nfs
3. Login as root and check content of /etc/kdump.conf

Test result:
After step2, An error occurred with follow error:
┌───────────────────────────────────────────────────────── An error occurred ─────────────────────────────────────────────────────────┐
│An error occurred                                                                                                                    │
│Unable to save to file!                                                                                                              │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│                                                                                                                                     │
│< Close >                                                                                                                            │
│            

so need assigned this bug again

Comment 3 Ryan Barry 2014-12-18 18:37:02 UTC
In order to not use a template, but reliably match and set values, we're using augeas, which is failing to parse the file (so it refuses to set or save values).

Augeas does not support fence_kdump_nodes or fence_kdump_args. Ill file a bug against augeas about this and block against it. Are there any other arguments can we expect to see?

Comment 4 Martin Perina 2014-12-18 20:07:53 UTC
Options fence_kdump_nodes and fence_kdump_args were added into standard kexec-tools distribution in Fedora 20, RHEL 6.6 and RHEL 7.1 to support oVirt kdump integration. And only fence_kdump_* options are altered by oVirt host deploy (along with some comment lines).

Comment 5 Ryan Barry 2014-12-18 22:17:25 UTC
Though the support landed earlier, support hasn't made it to augeas yet. I asked because I'm curious whether there are any other options which augeas doesn't currently support but may be used.

Comment 6 Yaniv Lavi 2015-01-12 10:59:55 UTC
Moving to 3.5.1 because this issue doesn't happen in regular flows.

Comment 8 Yaniv Lavi 2015-04-30 08:34:15 UTC
This has a complex fix and we will fix this for zstream only if a customer reports this issue. Please reopen if that is the case.


Note You need to log in before you can comment on or make changes to this bug.