Bug 1175854 - Augeas does not support fence_kdump* options in kdump.conf
Summary: Augeas does not support fence_kdump* options in kdump.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1139298
Blocks: 1123414 1181278
TreeView+ depends on / blocked
 
Reported: 2014-12-18 18:37 UTC by Ryan Barry
Modified: 2015-07-22 05:41 UTC (History)
6 users (show)

Fixed In Version: augeas-1.0.0-9.el6
Doc Type: Bug Fix
Doc Text:
Previously, the Augeas utility did not correctly parse "ssh" and "fence_kdump_*" parameters in the /etc/kdump.conf file. As a consequence, using Augeas to edit these parameters in kdump configuration failed. With this update, Augeas has been updated to parse "ssh" and "fence_kdump_*" as intended, and the described problem no longer occurs.
Clone Of:
: 1181278 (view as bug list)
Environment:
Last Closed: 2015-07-22 05:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1256 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-07-20 17:50:00 UTC
Red Hat Bugzilla 1175856 None None None Never

Internal Links: 1175856

Description Ryan Barry 2014-12-18 18:37:23 UTC
Description of problem: Augeas does not support fence_kdump* options in kdump.conf


Version-Release number of selected component (if applicable):
augeas-1.0.0-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Add any of the options from bz#1083938
2. Try to use augtool

Actual results:
Augeas fails.

print /augeas/files/etc/kdump.conf/error shows parsing failed

Expected results:
Augeas can parse kdump.conf with the new options

Additional info:
See bz#1083938 for more info

Comment 2 Dominic Cleal 2015-01-02 10:58:52 UTC
Fixed in 0951590, a8d43f6

Comment 6 Hu Zhang 2015-03-03 09:59:18 UTC
Reproduced with augeas-1.0.0-8.el6.x86_64.

Verified with the package:
augeas-1.0.0-9.el6.x86_64

verify steps:
1. Add lines
 "fence_kdump_args -p 7410 -f auto -c 0 -i 10
  fence_kdump_nodes node1 node2" to file /etc/kdump.conf"

2. #augtool -b
   augtool> print /files/etc/kdump.conf
...
...
/files/etc/kdump.conf/fence_kdump_args = "-p 7410 -f auto -c 0 -i 10"
/files/etc/kdump.conf/fence_kdump_nodes
/files/etc/kdump.conf/fence_kdump_nodes/1 = "node1"
/files/etc/kdump.conf/fence_kdump_nodes/2 = "node2"
   augtool> print /augeas/files/etc/kdump.conf/error
Comments: no error returns

parse successfully.

Verified.

Comment 8 errata-xmlrpc 2015-07-22 05:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1256.html


Note You need to log in before you can comment on or make changes to this bug.