Bug 1123444 - Backport EQL live migration fix to OSP5
Summary: Backport EQL live migration fix to OSP5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Eric Harney
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1108193 1119353 1122587 1122606
TreeView+ depends on / blocked
 
Reported: 2014-07-25 16:18 UTC by arkady kanevsky
Modified: 2019-02-17 12:33 UTC (History)
12 users (show)

Fixed In Version: openstack-cinder-2014.1.2-2.el7ost openstack-cinder-2014.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, the multihost flag was not enabled for volumes using Equallogic storage. Consequently, live migration would fail when using Equallogic storage. This update enables multihost for the volume on the storage backend. As a result, live migration is expected to complete successfully.
Clone Of:
Environment:
Last Closed: 2014-09-02 18:21:37 UTC


Attachments (Terms of Use)
Cinder volume log and screenshoot (328.59 KB, application/octet-stream)
2014-08-27 12:37 UTC, Tzach Shefi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1129 normal SHIPPED_LIVE openstack-cinder bug fix advisory 2014-09-02 22:20:47 UTC
OpenStack gerrit 103647 None None None Never

Description arkady kanevsky 2014-07-25 16:18:37 UTC
Description of problem:
The following code was merged upstream to enable multi-host access to EQL blokc back end:

https://bugs.launchpad.net/cinder/+bug/1296677

This a required fix for live migration with EQL back end and for using EQL for ephemeral storage.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 arkady kanevsky 2014-08-13 20:20:02 UTC
Not sure what additional info you need, if any?
Also let me, my QE team, when new drop is avalable with the fix for us to test.

Comment 6 Tzach Shefi 2014-08-27 12:37:15 UTC
Created attachment 931439 [details]
Cinder volume log and screenshoot

Comment 7 Tzach Shefi 2014-08-27 12:38:27 UTC
Verified, Please review process as I was missing details and guessed them! 

RHEL7
python-cinder-2014.1.2-2.el7ost.noarch
openstack-cinder-2014.1.2-2.el7ost.noarch
python-cinderclient-1.0.9-1.el7ost.noarch


1. Packstack deployed AIO+a second compute node
2. Configured AIO /var/lib/nova/instance as shared NFS storage for live migration.
3. Mapped second compute's nova folder to NFS share on AIO.
4. Configured needed live migration settings under Nova.conf
5. Tested live migration with Cirros instance. 
6. Configured Cinder driver for Dell EQL PS6000 ISCSI storage
7. Created empty Cinder volume, checked on Dell volume was created.
8. Attached this new volume to instance on AIO compute host.
9. Noticed a single ISCSI connection on Dell to this volume.
10.Live migrated instance with attached volume to second compute node.
11.During migration noticed Dell volume info showed two ISCSI connections.
12.Migration completed successfully, cinder volume remined attached.
13.Checked volume info again Dell again shows only one ISCSI connection.  

Attached Cinder logs and srceenshot of volume info. 

Hope this verifies bug, wasn't sure which live migration to use. 
BTW when I tried to create a new volume from a Glance image I ran into problems, opening a new bug about it, I'll add BZ number as comment later.

Comment 8 Rajini Karthik 2014-08-27 15:32:26 UTC
The verification process looks correct. Thanks for verifying.

Comment 9 Rajini Karthik 2014-08-27 15:32:37 UTC
The verification process looks correct. Thanks for verifying.

Comment 10 Tzach Shefi 2014-08-28 09:12:22 UTC
Create volume from image fails with EQL driver, new bug
https://bugzilla.redhat.com/show_bug.cgi?id=1134770

Comment 12 errata-xmlrpc 2014-09-02 18:21:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1129.html


Note You need to log in before you can comment on or make changes to this bug.