Bug 1122587 - [RFE] Need an ability to specify per infrastructure network if Foreman/Staypuft admin node should provide ip address management
Summary: [RFE] Need an ability to specify per infrastructure network if Foreman/Staypu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Alexander Chuzhoy
URL: https://trello.com/c/YoAnSm8k
Whiteboard: MVP
Depends On: 1122550 1122556 1123444
Blocks: 1108193 1119353 1122606
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:39 UTC by arkady kanevsky
Modified: 2016-04-26 16:12 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1122583
: 1122606 (view as bug list)
Environment:
Last Closed: 2014-11-04 17:01:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description arkady kanevsky 2014-07-23 14:39:19 UTC
+++ This bug was initially created as a clone of Bug #1122583 +++

Description of problem:
For OSP deployments some networks require DNS service to be provided 

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2014-07-23 14:42:05 UTC
This real requirement for provioner network.
Under Customer/deployer control which other networks need DNS.

Comment 3 Mike Burns 2014-07-25 13:34:26 UTC
The RHEL-OSP installer currently runs only on RHEL 6.  Changes made on RHEL 6 will apply to RHEL-OSP deployments on both RHEL 6 and RHEL 7.  Closing this bug as a duplicate since we only need to track it in 1 place.

*** This bug has been marked as a duplicate of bug 1122583 ***

Comment 4 Perry Myers 2014-08-06 21:25:37 UTC
We don't need Foreman server to provide DHCP for all of the separate networks (Storage, Management, APIs, Tenant).  The two options will be for Foreman to statically assign addresses out of a pool (specified by a range) or for the existing infrastructure to have its own DHCP server.

However... We can't expect DNS to be provided in the case where static addressing is used, so Foreman will need to run a DNS server that covers all of the different networks so we have proper resolution for all nodes' interfaces. 

It's unclear as to whether or not this is a definite need or a nice to have.  We need info from the Ceph team to figure out if DNS resolvability is a requirement for their software.

Comment 6 Mike Burns 2014-10-01 17:48:19 UTC
Updating title based on comment 4

Comment 7 Mike Burns 2014-10-01 17:51:48 UTC
setting up and managing DNS is outside the scope of this request based on comment 4.  We'll assume that a DNS service exist on the network.

Comment 9 Alexander Chuzhoy 2014-10-06 18:47:50 UTC
Verified: rhel-osp-installer-0.4.1-2.el6ost.noarch

We now have the ability to specify how the IP is provided/assigned per network.
The options are:
None (means external DHCP is used)
DHCP  (foreman actually manages the DHCP)
Internal DB (means the admin has to provide a range of addresses, the bootmode of the NIC should be set to static)

Comment 11 Mike Burns 2014-10-24 13:25:50 UTC
testonly, feature existed in A1, no doc text needed

Comment 13 errata-xmlrpc 2014-11-04 17:01:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.