Bug 1123469 - SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the directory lock.
Summary: SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the director...
Keywords:
Status: CLOSED DUPLICATE of bug 1123423
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e43cc3f91668363b3ab1da9b566...
: 1123532 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 18:56 UTC by lejeczek
Modified: 2014-07-31 13:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 13:30:58 UTC


Attachments (Terms of Use)

Description lejeczek 2014-07-25 18:56:52 UTC
Description of problem:
SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the directory lock.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that alsactl should be allowed write access on the lock directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep alsactl /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:alsa_t:s0
Target Context                system_u:object_r:var_lock_t:s0
Target Objects                lock [ dir ]
Source                        alsactl
Source Path                   /usr/sbin/alsactl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           alsa-utils-1.0.28-1.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-67.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc6.git1.1.fc22.x86_64 #1
                              SMP Tue Jul 22 13:57:51 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-07-25 19:55:41 BST
Last Seen                     2014-07-25 19:55:41 BST
Local ID                      8015df86-8676-4a34-a8cd-566fdc98219b

Raw Audit Messages
type=AVC msg=audit(1406314541.795:545): avc:  denied  { write } for  pid=7188 comm="alsactl" name="lock" dev="tmpfs" ino=10942 scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=dir permissive=1


type=AVC msg=audit(1406314541.795:545): avc:  denied  { add_name } for  pid=7188 comm="alsactl" name="asound.state.lock" scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=dir permissive=1


type=AVC msg=audit(1406314541.795:545): avc:  denied  { create } for  pid=7188 comm="alsactl" name="asound.state.lock" scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file permissive=1


type=AVC msg=audit(1406314541.795:545): avc:  denied  { open } for  pid=7188 comm="alsactl" path="/run/lock/asound.state.lock" dev="tmpfs" ino=78801 scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1406314541.795:545): arch=x86_64 syscall=open success=yes exit=EINTR a0=7fb52b33f7b3 a1=c2 a2=1a4 a3=0 items=0 ppid=1 pid=7188 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=alsactl exe=/usr/sbin/alsactl subj=system_u:system_r:alsa_t:s0 key=(null)

Hash: alsactl,alsa_t,var_lock_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-67.fc22.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc6.git1.1.fc22.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-07-31 13:29:44 UTC
*** Bug 1123532 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2014-07-31 13:30:58 UTC

*** This bug has been marked as a duplicate of bug 1123423 ***


Note You need to log in before you can comment on or make changes to this bug.