Bug 1123532 - SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the directory lock.
Summary: SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the director...
Keywords:
Status: CLOSED DUPLICATE of bug 1123469
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e43cc3f91668363b3ab1da9b566...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 01:22 UTC by Adam Williamson
Modified: 2014-07-31 13:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 13:29:44 UTC


Attachments (Terms of Use)

Description Adam Williamson 2014-07-26 01:22:36 UTC
Description of problem:
Happened during a yum update in which alsa-utils was updated to 0:1.0.28-1.fc21.
SELinux is preventing /usr/sbin/alsactl from 'write' accesses on the directory lock.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that alsactl should be allowed write access on the lock directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep alsactl /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:alsa_t:s0
Target Context                system_u:object_r:var_lock_t:s0
Target Objects                lock [ dir ]
Source                        alsactl
Source Path                   /usr/sbin/alsactl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           alsa-utils-1.0.28-1.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-67.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc6.git1.2.fc22.x86_64 #1
                              SMP Tue Jul 22 14:49:51 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-07-25 18:20:31 PDT
Last Seen                     2014-07-25 18:20:31 PDT
Local ID                      5ae116a9-35bf-4cdc-a1fb-20eea228fc12

Raw Audit Messages
type=AVC msg=audit(1406337631.664:1166): avc:  denied  { write } for  pid=8303 comm="alsactl" name="lock" dev="tmpfs" ino=14342 scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=dir permissive=1


type=AVC msg=audit(1406337631.664:1166): avc:  denied  { add_name } for  pid=8303 comm="alsactl" name="asound.state.lock" scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=dir permissive=1


type=AVC msg=audit(1406337631.664:1166): avc:  denied  { create } for  pid=8303 comm="alsactl" name="asound.state.lock" scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file permissive=1


type=AVC msg=audit(1406337631.664:1166): avc:  denied  { open } for  pid=8303 comm="alsactl" path="/run/lock/asound.state.lock" dev="tmpfs" ino=7053339 scontext=system_u:system_r:alsa_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1406337631.664:1166): arch=x86_64 syscall=open success=yes exit=EINTR a0=7fc5a903b7b3 a1=c2 a2=1a4 a3=0 items=0 ppid=1 pid=8303 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=alsactl exe=/usr/sbin/alsactl subj=system_u:system_r:alsa_t:s0 key=(null)

Hash: alsactl,alsa_t,var_lock_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-67.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc6.git1.2.fc22.x86_64
type:           libreport

Potential duplicate: bug 1123469

Comment 1 Miroslav Grepl 2014-07-31 13:29:44 UTC

*** This bug has been marked as a duplicate of bug 1123469 ***


Note You need to log in before you can comment on or make changes to this bug.