Bug 1123533 - dnf: UnicodeDecodeError in repolist
Summary: dnf: UnicodeDecodeError in repolist
Keywords:
Status: CLOSED DUPLICATE of bug 1118809
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 01:50 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2014-07-28 05:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 05:00:40 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2014-07-26 01:50:33 UTC
Description of problem:

Saw the following backtrace today:

[test@fedora21-amd64 ~]$ dnf repolist
Fedora 21 - x86_64                                                4.1 MB/s |  39 MB     00:09    
Failed to synchronize cache for repo 'jwboyer-kernel-playground' from '[u'http://copr-be.cloud.fedoraproject.org/results/jwboyer/kernel-playground/fedora-21-x86_64/']': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, wyłączanie.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1170, in run
    self.base.plugins.run_sack()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 139, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/generate_completion_cache.py", line 55, in sack
    self._out('Can\'t write completion cache: %s' % e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 20: ordinal not in range(128)


Version-Release number of selected component (if applicable):
dnf-0.5.4-1.fc21.noarch

How reproducible:
Not reproducible, when I try the same command again.

Additional info:
$ locale
LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

Comment 1 Ales Kozumplik 2014-07-28 05:00:40 UTC

*** This bug has been marked as a duplicate of bug 1118809 ***


Note You need to log in before you can comment on or make changes to this bug.