Bug 1123551 - WINE from EPEL7 unusable due to missing 32-bit support
Summary: WINE from EPEL7 unusable due to missing 32-bit support
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1132566 1180222 1190600 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 09:39 UTC by Colin Finck
Modified: 2015-02-09 14:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-27 19:04:42 UTC


Attachments (Terms of Use)

Description Colin Finck 2014-07-26 09:39:28 UTC
Description of problem:
  EPEL7 ships WINE, but this version is mostly unusable due to missing support for 32-bit Windows binaries (i.e. 99% of the available Windows binaries). Trying to launch one fails with "Invalid EXE format".

  This was already partly addressed in bug 1117422, but instead of adding the missing 32-bit support here, the "solution" was to just remove it altogether.

Version-Release number of selected component (if applicable):
  wine-1.7.22-1.el7.x86_64

Steps to Reproduce:
1. Download any Windows binary, they are usually 32-bit.
2. Try "wine binary.exe".

Actual results:
  Error message "Invalid EXE format".

Expected results:
  Application should work.

Comment 1 Michael Cronenworth 2014-07-26 23:47:05 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1117422#c6

Comment 2 Colin Finck 2014-07-27 09:17:18 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1117422#c9

If RHEL/CentOS doesn't ship the required i686 dependencies for WINE, you need to build them as well for EPEL. Do you really want to sacrifice all CentOS users needing WINE just for the sake of having everything 64-bit?

Comment 3 Michael Cronenworth 2014-07-27 19:04:42 UTC
EPEL does not support 32-bit packages. There is no way to build the 32-bit environment and ship it in the EPEL repositories. If you wish to change this it would be best to start this discussion on the EPEL mailing list. I do not have the power to change EPEL policy or RHEL policy for that matter.

Comment 4 Michael Cronenworth 2014-08-21 14:52:11 UTC
*** Bug 1132566 has been marked as a duplicate of this bug. ***

Comment 5 Michael Cronenworth 2015-01-08 16:20:32 UTC
*** Bug 1180222 has been marked as a duplicate of this bug. ***

Comment 6 Michael Cronenworth 2015-02-09 14:10:21 UTC
*** Bug 1190600 has been marked as a duplicate of this bug. ***

Comment 7 Michael Cronenworth 2015-02-09 14:59:59 UTC
*** Bug 1190600 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.