Bug 1123573 - Please provide /usr/bin/emacs-nox
Summary: Please provide /usr/bin/emacs-nox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 18:42 UTC by Krzesimir Nowak
Modified: 2014-08-18 11:47 UTC (History)
6 users (show)

Fixed In Version: emacs-24.3-22.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 02:52:05 UTC


Attachments (Terms of Use)

Description Krzesimir Nowak 2014-07-26 18:42:26 UTC
There's no version-agnostic way of running emacs-nox. Such thing (a symlink to versioned emacs-nox binary) would be useful for configurations that survive updating to next version of Fedora. An example would be git's core.editor used for writing commit messages.

Also, emacs-nox is way easier to type than emacs-24.3-nox.

Comment 2 Fedora Update System 2014-08-01 13:41:43 UTC
emacs-24.3-19.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-19.fc20

Comment 3 Fedora Update System 2014-08-01 23:55:25 UTC
Package emacs-24.3-19.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.3-19.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9103/emacs-24.3-19.fc20
then log in and leave karma (feedback).

Comment 4 Richard W.M. Jones 2014-08-02 07:36:56 UTC
This change seems to mean that:

  BuildRequires: emacs-nox

no longer provides a /usr/bin/emacs binary.  See this
build failure:

https://kojipkgs.fedoraproject.org//work/tasks/2604/7232604/build.log

I don't know if that was intentional or not.

Comment 5 Richard W.M. Jones 2014-08-02 08:16:46 UTC
(In reply to Richard W.M. Jones from comment #4)
> This change seems to mean that:
> 
>   BuildRequires: emacs-nox
> 
> no longer provides a /usr/bin/emacs binary.  See this
> build failure:
> 
> https://kojipkgs.fedoraproject.org//work/tasks/2604/7232604/build.log
> 
> I don't know if that was intentional or not.

Actually it's worse than that.  The package now "Provides" /usr/bin/emacs
but doesn't actually contain the binary.  Something strange/broken
is going on anyway.

Comment 6 Petr Hracek 2014-08-04 07:03:59 UTC
The change was only to add symlink /usr/bin/emacs-nox to alternatives etc.
build finished successfully.
http://koji.fedoraproject.org/koji/buildinfo?buildID=549708

BuildRequires is not a right way.
emacs-nox is emacs witout XWindow.

Comment 7 Petr Hracek 2014-08-04 07:06:25 UTC
I hope that %posttrans nox is used only during installation emacs-nox package.

Comment 8 Petr Hracek 2014-08-04 07:32:14 UTC
Well, I uninstalled emacs completely with all his subpackages and installed them again (build via mock) and emacs binary exists on the system.

I could not reproduced your error unfortunately.

Comment 9 Richard W.M. Jones 2014-08-04 08:18:49 UTC
(In reply to Petr Hracek from comment #6)
> The change was only to add symlink /usr/bin/emacs-nox to alternatives etc.
> build finished successfully.
> http://koji.fedoraproject.org/koji/buildinfo?buildID=549708
> 
> BuildRequires is not a right way.
> emacs-nox is emacs witout XWindow.

All I'm saying is that I have a package which does:

  BuildRequires: /usr/bin/emacs

and it pulled in emacs-nox but there was no emacs binary.  See for
yourself:

http://koji.fedoraproject.org/koji/buildinfo?buildID=549863

root.log shows:
DEBUG util.py:283:   emacs-nox               i686   1:24.3-20.fc22                      build 2.2 M

build.log fails:
/var/tmp/rpm-tmp.wBSSfz: line 84: /usr/bin/emacs: No such file or directory

http://pkgs.fedoraproject.org/cgit/coq.git/commit/?id=bc0153ad51c41f4d73d9ce4ea2e0f05885180b9f
BR was /usr/bin/emacs

Comment 10 Petr Hracek 2014-08-04 08:31:26 UTC
I have catched the problem. You are right
in package nox is emacs file marked as ghost which is wrong.

Fix is ongoing. Rawhide first.

Comment 12 Fedora Update System 2014-08-04 13:59:42 UTC
emacs-24.3-21.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-21.fc20

Comment 13 Fedora Update System 2014-08-06 05:10:47 UTC
emacs-24.3-22.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-22.fc20

Comment 14 Fedora Update System 2014-08-07 15:25:33 UTC
Package emacs-24.3-22.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.3-22.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9169/emacs-24.3-22.fc20
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-08-15 02:52:05 UTC
emacs-24.3-22.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Jonathan Abbey 2014-08-15 19:55:00 UTC
Unfortunately, now that this change has been made, 'emacs' no longer exists on my systems if I only have emacs-nox installed.  *Very* disconcerting to have emacs disappear after doing a yum update.

Is there any way to make /usr/bin/emacs resolve to /etc/alternatives/emacs-nox or something if emacs-nox is installed but emacs is not?

Comment 17 Jonathan Abbey 2014-08-15 19:56:34 UTC
This is emacs-nox-24.3-22.fc20.x86_64, emacs-common-24.3-22.fc20.x86_64.

Comment 18 Bill McGonigle 2014-08-16 17:36:36 UTC
bug 1130587 was filed for /usr/bin/emacs going missing from Fedora 20 with the current 'stable' update.

Comment 19 Jan Chaloupka 2014-08-18 05:34:21 UTC
Hello, Jonathan,

you can create symlink to /usr/bin/emacs-nox.

# ln -s /usr/bin/emacs-nox /usr/bin/emacs

Justification: as emacs-nox package provides emacs without x, the binary is named emacs-nox, not emacs. Having emacs and emacs-nox packages installed together, one has to distinguish between emacs with x windows and the one without.

Yes, you are right, it is unpleasant. Suddenly, emacs is gone without any notice.

Regards

Jan

Comment 20 Jan Chaloupka 2014-08-18 11:47:00 UTC
Ongoing resolution in bug 1130587.


Note You need to log in before you can comment on or make changes to this bug.