Bug 1130587 - emacs-nox no longer provides /usr/bin/emacs
Summary: emacs-nox no longer provides /usr/bin/emacs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 15:22 UTC by Erik Logtenberg
Modified: 2014-08-21 09:44 UTC (History)
7 users (show)

Fixed In Version: emacs-24.3-24.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 09:44:31 UTC


Attachments (Terms of Use)

Description Erik Logtenberg 2014-08-15 15:22:39 UTC
Description of problem:

After updating to latest emacs-nox package, I can no longer run "emacs". I checked and emacs-nox (emacs-nox-24.3-22.fc20.x86_64) now contains these files:

$ rpm -ql emacs-nox
/usr/bin/emacs-24.3-nox
/usr/bin/emacs-nox

Previously (emacs-nox-24.3-17.fc20.x86_64) it was like this:

$ rpm -ql emacs-nox
/usr/bin/emacs
/usr/bin/emacs-24.3-nox

Comment 1 Bill McGonigle 2014-08-16 17:34:41 UTC
Looks like fallout from bug 1123573 which wasn't addressed.

Urgent/Urgent please!

Comment 2 Jan Chaloupka 2014-08-18 05:27:44 UTC
Hello, Erik, Bill,

this is a proper fix as emacs-nox package provides emacs without x. Thus the binary is named emacs-nox, not emacs.

If you really need emacs instead of emacs-nox, create symlink to /usr/bin/emacs-nox.

# ln -s /usr/bin/emacs-nox /usr/bin/emacs

Comment 3 Bill McGonigle 2014-08-18 06:04:06 UTC
@Jan are you serious?  X11 has always been an optional mode for emacs, ever since emacs first got X11 support.

We've had /usr/bin/emacs as a text-mode emacs since at least Redhat Linux 7, and through the next 22 releases of Redhat and Fedora - you feel that this has been a bug all along that ought to be finally "fixed" mid-stream in Fedora 20?

At the very least you're breaking workflows in the middle of a release and ought to propose such a significant change for f21.  There are millions of users who are used to typing 'emacs' and now that's broken without notice.

Comment 4 Jan Chaloupka 2014-08-18 06:31:24 UTC
Lets reopen this bug. Thank you for explanation.

Comment 5 Erik Logtenberg 2014-08-18 08:16:05 UTC
I'm with Bill. Regardless of wether or not it is a good idea to change emacs to emacs-nox, it is certainly a horrible idea to do that in the middle of Fedora 20.

Propose it for F21 and I for one certainly hope it doesn't get approved. As for F20, please bring emacs without -nox back asap.

Comment 6 Jan Chaloupka 2014-08-18 08:29:58 UTC
I agree, already testing new build.

Comment 8 Fedora Update System 2014-08-18 10:55:04 UTC
emacs-24.3-24.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-24.fc20

Comment 9 Bill McGonigle 2014-08-18 11:44:08 UTC
Thanks.  Downloaded the srpm from koji and built/installed on my f20 laptop - looks good.  I'll add karma once it pushes to -testing.

Comment 11 Jan Chaloupka 2014-08-18 11:46:02 UTC
Thanks Bill for testing.

Comment 12 Erik Logtenberg 2014-08-18 11:48:48 UTC
Downloaded the binary package for F20 [1], installed, tested and confirmed. This fixes the issue. Jan Chaloupka, thank you very much.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=565242

Comment 13 Fedora Update System 2014-08-19 07:09:12 UTC
Package emacs-24.3-24.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.3-24.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9582/emacs-24.3-24.fc20
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2014-08-21 09:44:31 UTC
emacs-24.3-24.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.