Bug 112358 - 'rpmdb: Program version 4.2 doesn't match environment version'
'rpmdb: Program version 4.2 doesn't match environment version'
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
: 112378 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 07:00 EST by Tim Waugh
Modified: 2007-04-18 13:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-18 07:35:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-12-18 07:00:37 EST
Description of problem:
The rpm-4.2.2-0.5 package fails to function with db4-4.1.25-14
installed, giving lots of errors when trying to upgrade packages etc.

Maybe it needs to have a conflicts: or requires:?

Version-Release number of selected component (if applicable):
rpm-4.2.2-0.5
db4-4.1.25-14

How reproducible:
100%

Steps to Reproduce:
1. Upgrade rpm but not db4.
Comment 1 Paul Nasrat 2003-12-18 07:10:22 EST
Note working fine here under 2.4.22-1.2132.nptl  + ea patch and glibc
2.3.3-1

rpm-4.2.2-0.6 (from cvs.colug.net)
db4-4.1.25-14

Going to test against a vanilla 2.6.0 kernel shortly.

Should add twaugh was seeing these errors:

error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages database in /var/lib/rpm

and

'rpmdb: Program version 4.2 doesn't match environment version'
Comment 2 Jeff Johnson 2003-12-18 07:17:19 EST
Try
    rm -f /var/lib/rpm/__db*

This is done in %post, but there was a build of -0.5
that did not have /usr/lib/rpm/rpmdb_stat in the rpm
package where needed. I suspect sopwith grabbed that.

Does that fix?
Comment 3 Tim Waugh 2003-12-18 07:33:17 EST
Yes, that fixes it.  Thanks.
Comment 4 Jeff Johnson 2003-12-18 07:35:37 EST
OK. A shame that the later -0.5 wasn't grabbed. Oh well, -0.6 today.

Comment 5 Jeff Johnson 2003-12-18 12:41:34 EST
*** Bug 112378 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.