Bug 112378 - rpm broken after updating rpm
Summary: rpm broken after updating rpm
Status: CLOSED DUPLICATE of bug 112358
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-18 17:36 UTC by John Ellson
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 19:00:28 UTC


Attachments (Terms of Use)

Description John Ellson 2003-12-18 17:36:42 UTC
Description of problem:
rpm broken after updating rpm

Version-Release number of selected component (if applicable):
rpm-4.2.2-0.5.i386.rpm

How reproducible:
I can't tell.  rpm is broken.

Steps to Reproduce:
1.rpm -Uvh rpm-4.2.2-0.5.i386.rpm  (plus some others from today's updates)
2.rpm -q rpm
3.
  
Actual results:
# rpm -q rpm
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
package rpm is not installed

Expected results:


Additional info:

Comment 1 Jeff Johnson 2003-12-18 17:41:31 UTC

*** This bug has been marked as a duplicate of 112358 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.