Bug 112378 - rpm broken after updating rpm
rpm broken after updating rpm
Status: CLOSED DUPLICATE of bug 112358
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 12:36 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2003-12-18 12:36:42 EST
Description of problem:
rpm broken after updating rpm

Version-Release number of selected component (if applicable):
rpm-4.2.2-0.5.i386.rpm

How reproducible:
I can't tell.  rpm is broken.

Steps to Reproduce:
1.rpm -Uvh rpm-4.2.2-0.5.i386.rpm  (plus some others from today's updates)
2.rpm -q rpm
3.
  
Actual results:
# rpm -q rpm
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
package rpm is not installed

Expected results:


Additional info:
Comment 1 Jeff Johnson 2003-12-18 12:41:31 EST

*** This bug has been marked as a duplicate of 112358 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.