Bug 1123591 - command-not-found proposes c++ needlessly
Summary: command-not-found proposes c++ needlessly
Keywords:
Status: CLOSED DUPLICATE of bug 1164410
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 01:17 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2015-01-11 11:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-11 11:28:24 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2014-07-27 01:17:38 UTC
Description of problem:
I have gcc installed.

$ which gcc
/usr/bin/gcc

When I type 'gcc <TAB><TAB>' I see the following prompt:

$ gcc Install package 'gcc-c++' to provide command 'c++'? [N/y] 

I don't know why command-not-found thinks I need c++, when I request gcc.

Version-Release number of selected component (if applicable):
PackageKit-command-not-found-0.9.4-2.fc21.x86_64

How reproducible:
100%

Comment 1 Richard Hughes 2014-07-28 17:23:18 UTC
Is this with bash-completion installed?

Comment 2 Zbigniew Jędrzejewski-Szmek 2014-07-28 17:27:35 UTC
Yes, bash-completion-1:2.1-5.fc21.noarch. Without bash-completion I get a list of files, as expected.

Comment 3 Ville Skyttä 2015-01-11 11:28:24 UTC
More discussion in bug 1164410

*** This bug has been marked as a duplicate of bug 1164410 ***


Note You need to log in before you can comment on or make changes to this bug.