Bug 1164410 - gcc -O2 <tab complete> tries to run f77
Summary: gcc -O2 <tab complete> tries to run f77
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1123591 1176715 1186641 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-15 00:53 UTC by Dr. David Alan Gilbert
Modified: 2015-11-13 02:21 UTC (History)
22 users (show)

Fixed In Version: PackageKit-1.0.6-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-25 12:19:26 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 91073 None None None Never

Description Dr. David Alan Gilbert 2014-11-15 00:53:56 UTC
Description of problem:
I've got gcc installed, but thankfully no Fortran compiler;
when I did tab complete on gcc (for a filename) I got it prompting me for installation of a g77 package

Version-Release number of selected component (if applicable):
bash-completion-2.1-6.20141110git52d8316.fc21.noarch
gcc-4.9.2-1.fc21.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Have gcc installed but no fortran
2. Type  gcc and hit tab

Actual results:
Install package 'compat-gcc-34-g77' to provide command 'f77'? [N/y]

Expected results:
tab completion of my .c filenames

Additional info:

Comment 1 Ville Skyttä 2014-11-15 18:15:58 UTC
I suppose this is PackageKit-command-not-found in action. Sure, the gcc completion tries to invoke f77 to do some optional stuff at initial load time, but I don't know why PackageKit-command-not-found would trigger on that. The user is not invoking f77 so I'd say it shouldn't.

Reassigning for comments, is this the expected behavior, and why? I suppose we could check for existence of every command that is allowed to not even exist before invoking but I'm afraid that's going to be a long painful road, more and messier code, and gcc completion or even the whole bash-completion certainly won't be the only thing affected.

Comment 2 Richard Hughes 2014-11-17 13:47:44 UTC
(In reply to rh from comment #0)
> when I did tab complete on gcc (for a filename) I got it prompting me for
> installation of a g77 package

The command not found program shouldn't be run when doing tab-complete. Can you describe exactly how you can reproduce this please.

Comment 3 Dr. David Alan Gilbert 2014-11-22 18:55:49 UTC
Richard:
  On my home machine, this does exactly as described in the bug, I type:


gcc 
  and then hit tab

and it says 'Install package 'compat-gcc-34-g77' to provide command 'f77'? [N/y]'

it only happens once in any shell, open a new shell and it repeats.

Now, it doesn't happen on my work laptop (that's also an f20 upgrade).

Comment 4 Andy Lutomirski 2014-12-28 22:05:08 UTC
This happens on my desktop machine that I upgraded from F20 to F21 as well.  It doesn't happen on my laptop, presumably because I uninstalled PackageKit.

Comment 5 Elliott Sales de Andrade 2015-01-10 03:23:42 UTC
Dupe of Bug 1123591.

Comment 6 Ville Skyttä 2015-01-11 11:28:24 UTC
*** Bug 1123591 has been marked as a duplicate of this bug. ***

Comment 7 Ville Skyttä 2015-01-28 09:18:27 UTC
*** Bug 1186641 has been marked as a duplicate of this bug. ***

Comment 8 Michael Hartman 2015-03-25 17:59:11 UTC
I confirm this is also happening to me. Fedora 21 x64.

Comment 9 Kalev Lember 2015-05-29 18:28:48 UTC
*** Bug 1176715 has been marked as a duplicate of this bug. ***

Comment 10 Nikos Mavrogiannopoulos 2015-06-23 10:47:35 UTC
This bug seems to be open for quite some time. Unless there is a fix please disable the component that causes the issue in the default installations of Fedora.

Comment 11 Ville Skyttä 2015-06-23 12:58:23 UTC
Candidate fix submitted upstream: https://bugs.freedesktop.org/show_bug.cgi?id=91073

Comment 12 Nikos Mavrogiannopoulos 2015-06-24 11:55:03 UTC
(In reply to Ville Skyttä from comment #11)
> Candidate fix submitted upstream:
> https://bugs.freedesktop.org/show_bug.cgi?id=91073

Thank you for addressing it.

Comment 13 Kalev Lember 2015-09-09 12:02:14 UTC
This should be fixed in PackageKit 1.0.8 in F22 and newer (already in stable), and PackageKit-1.0.6-2.fc21 in F21.

Comment 14 Fedora Update System 2015-09-09 12:08:03 UTC
PackageKit-1.0.6-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15440

Comment 15 Fedora Update System 2015-09-10 01:03:02 UTC
PackageKit-1.0.6-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update PackageKit'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15440

Comment 16 Fedora Update System 2015-09-25 12:19:16 UTC
PackageKit-1.0.6-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 hyxermail 2015-11-13 02:21:26 UTC
since Bug 1123591 is reported as duplicate of this bug, i'm going to continue here. i am using stock fedora 22 in VM. 

having similar problem albeit a different message:

Install package 'gcc-c++' to provide command 'c++'? [N/y]

Version-Release number of selected component (if applicable):
GNU bash, version 4.3.33(1)-release (x86_64-redhat-linux-gnu)
gcc version 5.1.1 20150618 (Red Hat 5.1.1-4) (GCC) 
Fedora verison: 4.0.4-301.fc22.x86_64

How reproducible:
50%

Steps to Reproduce:
1. login from ssh
2. Type gcc -o filename and hit tab


Note You need to log in before you can comment on or make changes to this bug.