Bug 1123646 - [SNAPSHOT]: Snapshot of volume with thick provisioned LV as bricks does not give proper error message
Summary: [SNAPSHOT]: Snapshot of volume with thick provisioned LV as bricks does not g...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: rjoseph
QA Contact: Rahul Hinduja
URL:
Whiteboard: SNAPSHOT
Depends On:
Blocks: 1145086
TreeView+ depends on / blocked
 
Reported: 2014-07-27 14:30 UTC by rjoseph
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1145086 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description rjoseph 2014-07-27 14:30:41 UTC
Description of problem:

Snapshot is supported only for thinly provisioned LV. Therefore to take snapshot all the bricks of the volume must be on thinly provisioned LV, 

Snapshot command does fail if one or more brick(s) are thick LV, but the error message is not clear. It fails with the following error message:

"snapshot create: failed: Commit failed on localhost. Please check log file for details."


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Snapshot command fail if one or more brick(s) are thick LV, but the error message is not clear. It fails with the following error message:

"snapshot create: failed: Commit failed on localhost. Please check log file for details."


Expected results:
Snapshot command should fail with accurate error message.

Additional info:

Comment 1 Anand Avati 2014-07-27 14:45:48 UTC
REVIEW: http://review.gluster.org/8377 (glusterd/snapshot: Proper err msg for snapshot create command) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Anand Avati 2014-07-28 06:33:06 UTC
REVIEW: http://review.gluster.org/8377 (glusterd/snapshot: Proper err msg for snapshot create command) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2014-07-30 06:17:28 UTC
REVIEW: http://review.gluster.org/8377 (glusterd/snapshot: Proper err msg for snapshot create command) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Anand Avati 2014-07-30 09:34:53 UTC
REVIEW: http://review.gluster.org/8377 (glusterd/snapshot: Proper err msg for snapshot create command) posted (#4) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 5 Anand Avati 2014-07-30 09:35:08 UTC
COMMIT: http://review.gluster.org/8377 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 8732ee5319bfe4649473c29458a6ab65b73d5516
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Sun Jul 27 10:36:52 2014 -0400

    glusterd/snapshot: Proper err msg for snapshot create command
    
    problem: Snapshot command fails if one or more bricks are not thinly
    provisioned. But the error message is a generic error message which
    is confusing to the user.
    
    fix: Provide correct error message in case of failure.
    
    Change-Id: Iad247f966423a8f73ef6da57cab7ed6cddc05861
    BUG: 1123646
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/8377
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.