Bug 1123656 - SELinux is preventing /usr/lib64/firefox/plugin-container from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
Summary: SELinux is preventing /usr/lib64/firefox/plugin-container from 'connectto' ac...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4fb47f9b3e43b47a48555d603e4...
: 1123657 1123658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 19:46 UTC by Vít Ondruch
Modified: 2014-07-29 14:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 14:30:56 UTC


Attachments (Terms of Use)

Description Vít Ondruch 2014-07-27 19:46:32 UTC
Description of problem:
SELinux is preventing /usr/lib64/firefox/plugin-container from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If you believe that plugin-container should be allowed connectto access on the X0 unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                @/tmp/.X11-unix/X0 [ unix_stream_socket ]
Source                        plugin-containe
Source Path                   /usr/lib64/firefox/plugin-container
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           firefox-31.0-1.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-67.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc6.git3.1.fc22.x86_64 #1
                              SMP Sat Jul 26 14:47:29 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-07-27 21:35:37 CEST
Last Seen                     2014-07-27 21:35:37 CEST
Local ID                      83044a36-d6db-4b4a-90fe-bfc308eecdae

Raw Audit Messages
type=AVC msg=audit(1406489737.811:448): avc:  denied  { connectto } for  pid=2766 comm="plugin-containe" path=002F746D702F2E5831312D756E69782F5830 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=unix_stream_socket permissive=1


type=SYSCALL msg=audit(1406489737.811:448): arch=x86_64 syscall=connect success=yes exit=0 a0=d a1=7fffefb22590 a2=14 a3=108 items=0 ppid=2692 pid=2766 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/firefox/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0 key=(null)

Hash: plugin-containe,mozilla_plugin_t,kernel_t,unix_stream_socket,connectto

Version-Release number of selected component:
selinux-policy-3.13.1-67.fc22.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc6.git3.1.fc22.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-07-28 06:20:26 UTC
*** Bug 1123657 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2014-07-28 06:20:35 UTC
*** Bug 1123658 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2014-07-28 06:24:26 UTC
Vit,
it looks you have badly labeled your system. Did you do a fresh install or uprade?

You will need to run

#touch autorelabel;reboot

to see if it works.

Comment 4 Vít Ondruch 2014-07-28 21:14:50 UTC
I freshly installed this Rawhide machine at 7th of June. Later just applied every update.

The autorelabel helped for this case it seems.

Comment 5 Miroslav Grepl 2014-07-29 14:30:56 UTC
I believe it should be OK now with the latest install images. There was a lorax bug which caused mislabeling issues.


Note You need to log in before you can comment on or make changes to this bug.