Bug 1123657 - SELinux is preventing /usr/lib64/firefox/plugin-container from 'open' accesses on the file /run/gdm/auth-for-vondruch-Rw6qbo/database.
Summary: SELinux is preventing /usr/lib64/firefox/plugin-container from 'open' accesse...
Keywords:
Status: CLOSED DUPLICATE of bug 1123656
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b5be2005aad214f674b6514763d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 19:47 UTC by Vít Ondruch
Modified: 2014-07-28 06:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 06:20:26 UTC


Attachments (Terms of Use)

Description Vít Ondruch 2014-07-27 19:47:19 UTC
Description of problem:
SELinux is preventing /usr/lib64/firefox/plugin-container from 'open' accesses on the file /run/gdm/auth-for-vondruch-Rw6qbo/database.

*****  Plugin restorecon (57.3 confidence) suggests   ************************

If you want to fix the label. 
/run/gdm/auth-for-vondruch-Rw6qbo/database default label should be xdm_var_run_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /run/gdm/auth-for-vondruch-Rw6qbo/database

*****  Plugin mozplugger (43.1 confidence) suggests   ************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.06 confidence) suggests   **************************

If you believe that plugin-container should be allowed open access on the database file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0
Target Context                system_u:object_r:var_run_t:s0
Target Objects                /run/gdm/auth-for-vondruch-Rw6qbo/database [ file
                              ]
Source                        plugin-containe
Source Path                   /usr/lib64/firefox/plugin-container
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           firefox-31.0-1.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-67.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc6.git3.1.fc22.x86_64 #1
                              SMP Sat Jul 26 14:47:29 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-07-27 21:35:37 CEST
Last Seen                     2014-07-27 21:35:37 CEST
Local ID                      a5386c30-239c-483a-9dc5-4081543253a1

Raw Audit Messages
type=AVC msg=audit(1406489737.813:449): avc:  denied  { open } for  pid=2766 comm="plugin-containe" path="/run/gdm/auth-for-vondruch-Rw6qbo/database" dev="tmpfs" ino=26627 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1406489737.813:449): arch=x86_64 syscall=open success=yes exit=EFAULT a0=7fffefb24e0f a1=0 a2=1b6 a3=ac items=0 ppid=2692 pid=2766 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/firefox/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0 key=(null)

Hash: plugin-containe,mozilla_plugin_t,var_run_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-67.fc22.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc6.git3.1.fc22.x86_64
type:           libreport

Potential duplicate: bug 889717

Comment 1 Miroslav Grepl 2014-07-28 06:20:26 UTC

*** This bug has been marked as a duplicate of bug 1123656 ***


Note You need to log in before you can comment on or make changes to this bug.