Bug 1123797 - libguestfs 'direct' backend should close file descriptors before exec-ing qemu to avoid leaking !O_CLOEXEC fds
Summary: libguestfs 'direct' backend should close file descriptors before exec-ing qem...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 7.1
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1021149 1123007
Blocks: 1028479
TreeView+ depends on / blocked
 
Reported: 2014-07-28 09:27 UTC by Qin Zhao
Modified: 2015-03-05 13:44 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.27.56-1.1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:44:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0303 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-03-05 17:34:44 UTC
IBM Linux Technology Center 113878 None None None 2019-06-18 10:31:19 UTC

Description Qin Zhao 2014-07-28 09:27:58 UTC
Description of problem:

See: https://bugzilla.redhat.com/show_bug.cgi?id=1123007

Version-Release number of selected component (if applicable):

libguestfs-1.22.6

How reproducible:

See: https://bugzilla.redhat.com/show_bug.cgi?id=1123007

Additional info:

Request to backport the patch to RHEL 7

Comment 2 Richard W.M. Jones 2014-07-28 09:33:31 UTC
Upstream fix is 115fcc34325f965ac3723683e4462fc667dcd254.
However the rebase already includes this fix so applying a
separate patch is not necessary.

Comment 3 Richard W.M. Jones 2014-07-28 09:57:58 UTC
QA: Please see the following comment for a test script you can
use to reproduce and verify the bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1123007#c4

Comment 4 bfan 2014-07-29 02:36:16 UTC
Reproduced, run the script, it hangs here,

Preparing the test, please wait a moment ...
Reading ...
IF the script hangs here, THEN the bug is NOT fixed.

Comment 6 yuliu 2014-11-10 09:36:03 UTC
Version: libguestfs-1.28.1-1.9.el7.x86_64
Execute the leak.pl script. Returns.

Verified.

Comment 8 errata-xmlrpc 2015-03-05 13:44:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0303.html


Note You need to log in before you can comment on or make changes to this bug.